Bug 40811 - X doesn't work properly with Graphics Blaster Exxtreme
X doesn't work properly with Graphics Blaster Exxtreme
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-15 22:33 EDT by udippel
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-03 15:40:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -n for -v see 40471 (372 bytes, text/plain)
2001-05-23 10:28 EDT, udippel
no flags Details
lspci -n for Blaster Exxtreme (372 bytes, text/plain)
2001-05-26 04:15 EDT, udippel
no flags Details
lspci -v Blaster Exxtreme (2.57 KB, text/plain)
2001-05-26 04:18 EDT, udippel
no flags Details
As requested, the XF86Config (14.16 KB, text/plain)
2001-05-26 04:21 EDT, udippel
no flags Details
As requested, the XF86Config-4 file ... (1.77 KB, text/plain)
2001-05-26 04:23 EDT, udippel
no flags Details

  None (edit)
Description udippel 2001-05-15 22:33:14 EDT
Description of Problem:
Using a Graphics Blaster Exxtreme / 3DLabs Permedia 2V, PCI, 4 MB RAM
is neither recognized in both text and graphic installer; nor with
Xconfigurator. In all cases it shows up as 'generic', 1MB Blaster. With all
tricks, I could not get it to work at more than 800x600 correctly.
Identical machine before and after pose no problems with RH6.2.
No problems with ATI PCII, 8MB, AGP; Matrox Mystique, 4MB, PCI. Even a
later change of the card (use the Exxtreme) (kudzo) results in the same
problem. On XFree 3.3.6 it is okay ...

How Reproducible: Just install (tried several times and ways; see above), 100%

Steps to Reproduce:
1. (obvious)

Actual Results:

Expected Results:

Additional Information:
Comment 1 Brent Fox 2001-05-17 13:45:43 EDT
Can you send the output of 'lspci -n' and 'lspci -v'.  Also, can you attach your
XF86Config and XF86Config-4 files?
Comment 2 udippel 2001-05-23 10:28:45 EDT
Created attachment 19393 [details]
lspci -n   for -v see 40471
Comment 3 udippel 2001-05-23 10:35:31 EDT
Need some more days to change the card back to Blaster. Currently, I can't
change the graphics card. Eventually, these dumps give some indication;
hopefully; even though there were produced with a fully functional card (ATI)
Comment 4 Brent Fox 2001-05-24 13:24:11 EDT
Well, I'll need the output of 'lspci -n' and 'lspci -v' with the Blaster video
card...I think that the problem lies somewhere in kudzu's pci id table.  The
Blaster may have a pci id that isn't in the table, thus resulting in the card
not being probed.

Putting in 'Needinfo' until you can swap the cards.
Comment 5 udippel 2001-05-26 04:00:24 EDT
Okay, here are the details (had the opportunity to swap!):
Xconfigurator identifies correctly: Permedia II 2D+3D
I enter the (correct) Monitor spec: Lite-On 1754
Detected memory: 1MB (it *is* 4MB and detected as such in any other RH-Distribution!)

Here we split into 2 alternatives:

1. I leave it like that. 1024x768 is displayed with 8 bits
2. I set the correct value: 4MB. The display is 640x400 with 24 bits

Attachments follow ...
Comment 6 udippel 2001-05-26 04:15:20 EDT
Created attachment 19711 [details]
lspci -n for Blaster Exxtreme
Comment 7 udippel 2001-05-26 04:18:12 EDT
Created attachment 19712 [details]
lspci -v Blaster Exxtreme
Comment 8 udippel 2001-05-26 04:21:05 EDT
Created attachment 19713 [details]
As requested, the XF86Config
Comment 9 udippel 2001-05-26 04:23:13 EDT
Created attachment 19714 [details]
As requested, the XF86Config-4 file ...
Comment 10 Brent Fox 2001-05-31 14:18:00 EDT
Hmmm...can you go to VC2 and run 'ddcprobe' and post the output?  That will tell
us what amount of RAM that the video card is returning.  The installer does some
calculating on the available screen resolutions based on the amount of video
ram.  So, if we're finding only 1MB, that would explain why the resolution
choices aren't what you expect.  

Also, does the same thing happen in text mode?
Comment 11 udippel 2001-05-31 20:32:58 EDT
Before I swap the cards again some questions-remarks:

 - Running 6.2, the card *returns* the correct amount (4MB)
 - Even if it returned the wrong amount (as it does), why does it not accept the manually corrected 4MB and displays 1024x768 with 24bits, but 640x400 instead? Whatever ddcprobe returns, it should (must?) work with the manually corrected values, shouldn't it?
 - what do you mean with 'text mode'?
Comment 12 Brent Fox 2001-06-04 11:42:40 EDT
1.  Yes, manual override should allow for a full choice of resolutions.  But I
am more concerned with the fact that 6.2 identifies the card correctly, but 7.1

2.  By text mode, I mean "Did you try the text based installer instead of the
graphical one?"  You can use text mode by typing 'text' at the bootup screen.
Comment 13 udippel 2001-06-04 20:34:37 EDT
Yes, tried both Text and Graphics install in those days. No difference.
Before I endanger my life by swapping the card again (it is the PC on which my wife usually prepares and stores her teaching material!); can you rather send me a complete testing and probing plan? So that a swap (and eventually loss of life) finally delivers *all* data and info for you guys to get things right?
Comment 14 Brent Fox 2001-07-03 15:40:00 EDT
I'd hate for you to lose your life over a video card.  Don't throw your life
away!  :)

Seriously, there's really not specific set of steps that I could give you that
would solve the problem.  It sounds like the kind of thing that we could fix if
we had one of these in the test lab and could try a bunch of different things. 
I just went through our big box o' video cards in the test lab, but I didn't
find one like yours.

Note You need to log in before you can comment on or make changes to this bug.