Bug 40858 - Incorrect data reading at not 1.44 format
Incorrect data reading at not 1.44 format
Status: CLOSED DUPLICATE of bug 40857
Product: Red Hat Linux
Classification: Retired
Component: mtools (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-16 07:47 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 07:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-16 07:47:28 EDT
Description of Problem:




  Incorrect data reading at not 1.44 format, with a non-standard format.




  Solved with configuration modification









How Reproducible:




  Follow the steps below









Steps to Reproduce:




  1. Low-level format with program like 'superformat'. 




      Format at 1.68M (like MS-DMF)




  2. High-level format: mformat -t 80 -h 2 -s 21 -r 3 -c 8 a: 




  3. Copy a file to floppy (with mcopy)




  4. mdir




  5. Read that file (with mcopy)




  6. diff file.writted file.readed









Actual Results:




  Data incongruencies. Data readed differ from writted.
  Note. Reproducibility depends on file size, greater files ensure more 

Additional Information:







Package: mtools-3.9.7-3
   Solution:
	Edit configuration file /etc/mtools.conf or apply diff.
                Remove de 1.44 directive.

********************************
--- mtools.conf.orig    Wed May 16 12:38:57 2001
+++ mtools.conf Wed May 16 12:43:39 2001
@@ -2,8 +2,10 @@
 # your architecture and comment out the "SAMPLE FILE" line below
 
 # Linux floppy drives
-drive a: file="/dev/fd0" exclusive 1.44m mformat_only
-drive b: file="/dev/fd1" exclusive 1.44m mformat_only
+#drive a: file="/dev/fd0" exclusive 1.44m mformat_only
+#drive b: file="/dev/fd1" exclusive 1.44m mformat_only
+drive a: file="/dev/fd0" exclusive mformat_only
+drive b: file="/dev/fd1" exclusive mformat_only
 
 # First SCSI hard disk partition
 #drive c: file="/dev/sda1"
********************************
Comment 1 Bernhard Rosenkraenzer 2001-05-16 13:04:45 EDT

*** This bug has been marked as a duplicate of 40857 ***

Note You need to log in before you can comment on or make changes to this bug.