Bug 408601 - Open Office Writer crashes on start up
Open Office Writer crashes on start up
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-12-03 08:17 EST by Nick Pierpoint
Modified: 2008-02-20 07:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-20 07:34:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output collected from oowriter > oowriter.out on startup (4.57 KB, text/plain)
2007-12-03 08:17 EST, Nick Pierpoint
no flags Details
.openoffice.org2.0 (576.26 KB, application/x-gzip)
2007-12-06 08:50 EST, Nick Pierpoint
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 86268 None None None Never

  None (edit)
Description Nick Pierpoint 2007-12-03 08:17:53 EST
Description of problem:

Open Office Writer crashes on startup

Version-Release number of selected component (if applicable):


How reproducible:

Happens every time

Steps to Reproduce:
1. Try to start oowriter
Actual results:

Window appears momentarily then vanishes

Expected results:

oowriter to start normally with blank document

Additional info:

[nick@rollins ~]$ oowriter > oowriter.out
ldd: /usr/lib*/openoffice.org2.0/program/libreg.so.3: No such file or directory

I don't have a /usr/lib/openoffice.org2.0 directory, just a /usr/lib/openoffice.org

I have tried creating a symbolic link as follows:

ln -s openoffice.org/ openoffice.org2.0

But same result although without the ldd error message
Comment 1 Nick Pierpoint 2007-12-03 08:17:53 EST
Created attachment 275661 [details]
Output collected from oowriter > oowriter.out on startup
Comment 2 Caolan McNamara 2007-12-03 09:13:40 EST
Ignore that ldd warning, it has no meaning here. I see
"SmartTagMgr::RegisterListener()" which sounds like a "smart tag manager".

Did you install any third party extensions ? , maybe the output of...

/usr/lib/openoffice.org/program/unopkg list --shared
/usr/lib/openoffice.org/program/unopkg list
Comment 3 Nick Pierpoint 2007-12-03 15:33:28 EST
[nick@rollins ~]$ /usr/lib/openoffice.org/program/unopkg list --shared
Segmentation fault
[nick@rollins ~]$ /usr/lib/openoffice.org/program/unopkg list
You need to close the already opened Extension Manager to continue.

ERROR: Lock file indicates that a concurrent Office process is running!

unopkg failed.
[nick@rollins ~]$ 
Comment 4 Caolan McNamara 2007-12-03 17:56:58 EST
This is horribly screwed up, you can rm ~/.openoffice.org*/*lock* to remove the
error from the "Lock file..."

a) did you install any third party extensions ?
b) is there anything else unusual that you are aware of that might indicate what
is unique to your setup ?
Comment 5 Nick Pierpoint 2007-12-04 05:26:46 EST
I remove the ~/.openofice.org2.0/.lock and tried again:

[nick@rollins .openoffice.org2.0]$ pwd
[nick@rollins .openoffice.org2.0]$ /usr/lib/openoffice.org/program/unopkg list
Segmentation fault
[nick@rollins .openoffice.org2.0]$ ls -a
.  ..  .lock  user
[nick@rollins .openoffice.org2.0]$ rm .lock
[nick@rollins .openoffice.org2.0]$ /usr/lib/openoffice.org/program/unopkg list
Segmentation fault
[nick@rollins .openoffice.org2.0]$ rm .lock

Also tried oowriter again with the same crash and (I think) the same trace:

---start copy and paste here---
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-27.fc7-i386
(V)    kernel is: Linux #1 SMP Thu Nov 1 21:09:24 EDT 2007 i686
athlon i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.4.fc7-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora release 7 (Moonshine)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x04baf33c: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x2133c
0x04bafcfb: 0x001cd374: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x21cfb
0x00110420: 0x00000000:  + 0x420 (__kernel_sigreturn + 0x0)
0x0376815c: 0x0008ab54: /usr/lib/openoffice.org/program/deployment680li.uno.so +
0x03770e56: 0x0008ab54: /usr/lib/openoffice.org/program/deployment680li.uno.so +
0x03773bd1: 0x0008ab54: /usr/lib/openoffice.org/program/deployment680li.uno.so +
0x037750d4: 0x0008ab54: /usr/lib/openoffice.org/program/deployment680li.uno.so +
0x0377a791: 0x0008ab54: /usr/lib/openoffice.org/program/deployment680li.uno.so +
0x02d1112e: 0x00f7b330: /usr/lib/openoffice.org/program/libsvx680li.so +
0x93012e (SmartTagMgr::RegisterListener() + 0x4c)
0x02d118e6: 0x00f7b330: /usr/lib/openoffice.org/program/libsvx680li.so +
0x9308e6 (SmartTagMgr::Init(rtl::OUString const&) + 0x148)
0x41dc5c51: 0x00ef4764: /usr/lib/openoffice.org/program/libsw680li.so + 0x87ec51
(SwSmartTagMgr::Get() + 0x91)
0x41b2fba4: 0x00ef4764: /usr/lib/openoffice.org/program/libsw680li.so + 0x5e8ba4
(SwLayIdle::DoIdleJob(SwLayIdle::IdleJobType, unsigned char) + 0xac)
0x41b33aec: 0x00ef4764: /usr/lib/openoffice.org/program/libsw680li.so + 0x5ecaec
(SwLayIdle::SwLayIdle(SwRootFrm*, SwViewImp*) + 0x38)
0x41adc9ea: 0x00ef4764: /usr/lib/openoffice.org/program/libsw680li.so + 0x5959ea
(ViewShell::LayoutIdle() + 0xb6)
0x41bbaa3e: 0x00ef4764: /usr/lib/openoffice.org/program/libsw680li.so + 0x673a3e
(SwDoc::DoIdleJobs(Timer*) + 0xb0)
0x41bbab8b: 0x00ef4764: /usr/lib/openoffice.org/program/libsw680li.so + 0x673b8b
(SwDoc::LinkStubDoIdleJobs(void*, void*) + 0x1d)
0x077b5e99: 0x000770cc: /usr/lib/openoffice.org/program/libsoffice.so + 0x3ce99
(Link::Call(void*) const + 0x1b)
0x05050bc5: 0x004d961c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x19bbc5 (Timer::Timeout() + 0x1f)
0x05050d0f: 0x004d961c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x19bd0f (Timer::ImplTimerCallbackProc() + 0x7b)
0x00f3a26c: 0x000a339c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x6526c (SalTimer::CallCallback() + 0x12)
0x00f3a07e: 0x000a339c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x6507e (X11SalData::Timeout() const + 0x2a)
0x00e29b8f: 0x0006f110: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x2bb8f (GtkXLib::timeoutFn(void*) + 0x6f)
0x00e29bc6: 0x0006f110: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x2bbc6 (call_timeoutFn + 0x1a)
0x07a5fdc6: 0x0009d29c: /lib/libglib-2.0.so.0 + 0x2bdc6
0x07a5f7f2: 0x0009d29c: /lib/libglib-2.0.so.0 + 0x2b7f2 (g_main_context_dispatch
+ 0x182)
0x07a627cf: 0x0009d29c: /lib/libglib-2.0.so.0 + 0x2e7cf
0x07a62d35: 0x0009d29c: /lib/libglib-2.0.so.0 + 0x2ed35
(g_main_context_iteration + 0x65)
0x00e287dc: 0x0006f110: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so +
0x2a7dc (GtkXLib::Yield(bool, bool) + 0x94)
0x00f43e59: 0x000a339c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x6ee59 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x0504b8ab: 0x004d961c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x1968ab (Application::Yield(bool) + 0x57)
0x0504b969: 0x004d961c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x196969 (Application::Execute() + 0x2b)
0x077b222b: 0x000770cc: /usr/lib/openoffice.org/program/libsoffice.so + 0x3922b
(desktop::Desktop::Main() + 0x15fb)
0x0505043b: 0x004d961c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x19b43b (ImplSVMain() + 0x49)
0x05050551: 0x004d961c: /usr/lib/openoffice.org/program/libvcl680li.so +
0x19b551 (SVMain() + 0x2d)
0x077ab88e: 0x000770cc: /usr/lib/openoffice.org/program/libsoffice.so + 0x3288e
(main + 0xe2)
0x00126f70: 0x0014fd7c: /lib/libc.so.6 + 0x15f70 (__libc_start_main + 0xe0)
0x080484c1: 0x000006d8: /usr/lib/openoffice.org/program/swriter.bin + 0x4c1
(main + 0x5d)
...end stackreport details ...
...start sample ldd details ...
...end sample ldd details ...
---end copy and paste here---

Comment 6 Nick Pierpoint 2007-12-04 05:28:10 EST
Forgot to say...

I don't have any third party extensions.

I have a pretty standard Fedora 7 set-up with a few pretty standard extras
(Nvidia drivers, Sun Java) - nothing too wild.
Comment 7 Caolan McNamara 2007-12-04 06:40:15 EST
Of course the nvidia drivers are notorious for side-effects. 

The only similar trace I can see is
http://qa.openoffice.org/issues/show_bug.cgi?id=81988 but doesn't seem too
likely unless there were loads of documents being opened by OOo at the same time
during startup.
Comment 8 Nick Pierpoint 2007-12-04 09:42:32 EST
I've disabled the nvidia drivers (although I've had Open Office working fine for
years with them enabled!) but it didn't help. Still crashes.

It only happens for oowriter by the way - no problems with oocalc and ooimpress.

Also crashes if I start ooffice and then create a new Text Document or try to
open an existing Text Document.
Comment 9 Caolan McNamara 2007-12-05 11:04:28 EST
I'm baffled as to why this is happening for just you. All I can suggest is to
first try this...

shut down office
> tar cvzf /tmp/backup.tar.gz ~/.openoffice.org2.0
> mv ~/.openoffice.org2.0 ~/.oldopenoffice.org2.0

and restart writer and see does it still happen, if the problem goes away then
send me that /tmp/backup.tar.gz
Comment 10 Nick Pierpoint 2007-12-06 08:48:58 EST
Thanks for your help with this - still no luck though.
Comment 11 Nick Pierpoint 2007-12-06 08:50:49 EST
Created attachment 279711 [details]

This is the directory dump you requested.
Comment 12 Caolan McNamara 2007-12-06 14:06:02 EST
Then I got nothing, all I can finally suggest is to de-install openoffice.org
e.g. from applications add/remove software and afterwards ensure that
/usr/lib/openoffice.org does not exist and then re-install it from add/remove
software on the vague possibility that somehow the openoffice.org component
registration database is somehow screwed up.
Comment 13 Nick Pierpoint 2007-12-07 05:02:41 EST
Thanks for your help on this. I tried the re-install yesterday but no luck -
still no oowriter. All very annoying - something somewhere has become screwed
up. Maybe I'll bring forward my Fedora 8 install plans :)
Comment 14 Caolan McNamara 2008-01-16 12:28:04 EST
ok, I give up on this one. I can only hope it is fixed in F8. There certainly is
no valgrind warnings or anything around the affected code that I can see in that
version unless there is some external trigger for this that we didn't discover.
Comment 15 Nick Pierpoint 2008-01-16 20:55:28 EST
I ended up re-installing Fedora 7 and OO Writer started working again.
Subsequently installed Fedora 8 and it continues to work. Must have been some
configuration or library conflict or screw up.
Comment 16 Caolan McNamara 2008-02-20 07:34:12 EST
Figured out why there is a crash, its a badly handled exception, don't know why
there is an exception though, but the problem and fix for the handling of the
exception is now upstreamed as
http://qa.openoffice.org/issues/show_bug.cgi?id=86268 and the fix checked into

Note You need to log in before you can comment on or make changes to this bug.