Bug 408641 - Broken: Only use VPN connection for these addresses
Broken: Only use VPN connection for these addresses
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 09:04 EST by Matthew Farrellee
Modified: 2007-12-03 10:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 10:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2007-12-03 09:04:57 EST
Description of problem:
When recreating my VPN configurations after upgrading to F8 from F7, I
discovered that when I check "Only use VPN connection for these addresses" the
"Forward" button will be grayed out, meaning I cannot specify the networks I
want to be on the VPN. This also happens when editing an existing VPN
configuration, with the "Apply" butting becoming grayed out instead.

Version-Release number of selected component (if applicable):
vpnc-0.5.1-2.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8

How reproducible:
Always

Steps to Reproduce:
1. NM-Applet->VPN Connections->Configure VPN...
2. Go Forward to "Create VPN Connection 2 of 2" and select "Optional" tab
3. Check the "Only use VPN connection for these addresses" box
  
Actual results:
"Forward" button is grayed out preventing the configuration of networks where
the VPN connection should be used

Expected results:
The "Forward" button would not be grayed out and only connections to the
specified networks will pass over the VPN

Additional info:
None
Comment 1 Denis Leroy 2007-12-03 10:03:21 EST
Well, checking the button is the first step. Next, you have to specify which
addresses to only use for the VPN, in the form x.x.x.x/n (for example,
10.6.0.0/16). The next/forward button is disabled because the entry in the
actual addresses text entry is invalid (i.e. empty). Maybe the GUI is confusing,
but i thought the fact that checking the box ungreys/enable the text field below
made this obvious...
Comment 2 Matthew Farrellee 2007-12-03 10:24:41 EST
I should have mentioned: I tried entering values I used to have in the box, but
the Forward/Apply button never became enabled. Playing around with this more, I
discovered that I was entering things like 10/8 and 192.168.10/24, instead of
10.0.0.0/8 and 192.168.10.0/24. The buttons become enabled if I specify all 4
octets. I guess this should become a feature request to support 10/8 along with
10.0.0.0/8.
Comment 3 Denis Leroy 2007-12-03 10:45:31 EST
This restriction is enforced by NetworkManager itself (see validate_ip4_route()
in NetworkManagerSystem.c), so you should file a bug against NM, preferably
directly upstream.

Closing this :-)

Note You need to log in before you can comment on or make changes to this bug.