Bug 40889 - DPMS does not work in XFree86-4.0.3-5
DPMS does not work in XFree86-4.0.3-5
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 54230 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-16 10:14 EDT by Sarantis Paskalis
Modified: 2007-04-18 12:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-27 14:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My /etc/X11/XF86Config-4 (1.66 KB, text/plain)
2001-05-24 05:54 EDT, Sarantis Paskalis
no flags Details
And here is my X11 startup file. Note that DPMS seems to be enabled. (21.04 KB, text/plain)
2001-05-24 05:57 EDT, Sarantis Paskalis
no flags Details

  None (edit)
Description Sarantis Paskalis 2001-05-16 10:14:44 EDT
Description of Problem:
I have the line
Option "DPMS"
in the MONITOR section of /etc/X11/XF86Config

The X server does not have DPMS enabled when started with "startx".
DPMS is enabled however, when I issue "xinit".

This is a S3Virge with a Sony 15SF2 monitor on a P133.

How Reproducible:
Every time

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Mike A. Harris 2001-05-20 19:31:43 EDT
Edit your config file and add:  Option "DPMS" to the Monitor section.
Comment 2 Sarantis Paskalis 2001-05-21 04:55:59 EDT
My original bug report states that I already have the Option "DPMS" in the
Monitor section.
Comment 3 Peter Janes 2001-05-22 22:38:07 EDT
I'm also seeing this behavour, running via gdm, using the tdfx driver for my
Voodoo3 3000.  Configuring from anaconda during the Red Hat 7.1 upgrade gave
Option "DPMS" in XF86Config-4, configuring via Xconfigurator gave Option "dpms";
neither works.

If I xset +dpms, I get the correct output from xset q:
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Enabled
  Monitor is On

However, after a short time, xset q shows:
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled

The screen never goes into standby, suspend or off.

I previously had RH7.0 installed on this system and DPMS support worked
flawlessly in both XFree86 3 and 4.
Comment 4 Mike A. Harris 2001-05-23 06:04:27 EDT
Original poster:  Please attach your XFree86 logfiles from this, and your
configuration file as well.  Use the file attachment link below, and do
not compress them.

So far every DPMS related bug reported has been misconfiguration, or someone
putting "Option DPMS" in the wrong file, or in the wrong location in the file,
or has been a bug in GNOME control panel, or xscreensaver.  DPMS works in
XFree86 for me, and I cannot reproduce any problems that end up being X
problems.
Comment 5 Sarantis Paskalis 2001-05-24 05:54:21 EDT
Created attachment 19470 [details]
My /etc/X11/XF86Config-4
Comment 6 Sarantis Paskalis 2001-05-24 05:57:15 EDT
Created attachment 19471 [details]
And here is my X11 startup file.  Note that DPMS seems to be enabled.
Comment 7 Sarantis Paskalis 2001-05-24 06:07:06 EDT
The funny part is of course here:

(sarantis@gallagher)~$ xset q | grep -1 DPMS
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 10    Suspend: 10    Off: 10
  DPMS is Disabled
Font cache:
(sarantis@gallagher)~$ 
Comment 8 Need Real Name 2001-06-07 10:59:53 EDT
I am having the same problem as the original submitter.
It is definitely NOT a DPMS-problem. DPMS-support in the X-server works.
It seems to be related to the xscreensaver or the Gnome control panel.
Some details:

RedHat 7.1 with XFree 4.0.3

When I activate the screensaver and power management via the screensaver menu
of the Gnome control panel, "xset -q" shows that DPMS is still turned off.
The screensaver will run indefinitely.

When I use xset to turn DPMS on, the command "xset -q" will reflect that change.
But when I check somewhat later, it is turned off again!

When I disable the screensaver and turn DPMS on using the xset utility, it
works.
But now I don't have those flashy screensavers.  :-(

Regards,
Toon.
Comment 9 Peter Janes 2001-06-07 12:42:12 EDT
For what it's worth, if I use the xscreensaver RPM from the 7.1 distribution,
DPMS works fine.  Using Ximian's RPM, though, causes DPMS to become disabled.
Comment 10 Mike A. Harris 2001-06-07 13:20:43 EDT
This is definitely not IMHO an XFree86 DPMS problem.  It is xscreensaver or
other applications which aren't doing stuff properly.  I personally do not
use xscreensaver or any other screensaver, and DPMS works for me perfectly
on all video hardware I have here to test with - mostly ATI/MGA, Cirrus Logic,
i740.  All work.

I believe xscreensaver has been fixed, but I don't recall the details, so
I'll let Bill comment/close the report.  Reassigning.
Comment 11 Bill Nottingham 2001-06-08 11:30:41 EDT
Yes, this is fixed in the xscreensaver & control-center from rawhide.
(3.32-2, 1.4.0.1-3)
Comment 12 Sarantis Paskalis 2001-06-12 06:20:30 EDT
I still see no difference

(sarantis@gallagher)~$ rpm -q xscreensaver
xscreensaver-3.32-2
(sarantis@gallagher)~$ rpm -q(sarantis@gallagher)~$ xset q | grep -1 DPMS
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled
Font cache:
(sarantis@gallagher)~$ control-center
control-center-1.4.0.1-3
(sarantis@gallagher)~$ xset q | grep -1 DPMS
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled
Font cache:

Actually, I do.  The standby, suspend, and off values were all 10 before that.
Comment 13 Mike A. Harris 2001-06-12 22:41:10 EDT
Ok, in order to troubleshoot this, I need you to please do the following
just for test purposes:

rpm -e xscreensaver
rpm -e control-panel

Force them if need be using --nodeps, or make absolutely sure that they
are completely totally disabled.  We want to have no screensaver whatsoever,
and absolutely no GUI tool touching DPMS settings for our test purposes here.
Completely disable everything that touches screensavers and/or DPMS with the
exception of the X server itself.

Now in the XF86Config-4 configuration file, put the following items in the
ServerFlags section:

Option "StandbyTime" "1"
Option "SuspendTime" "2"
Option "OffTime" "3"

Then in the Monitors section put:

Option "DPMS"

Start the X server, and see if DPMS works.  Does it?  Make SURE you are using
the proper config file and proper X server.  (4.0.3)



Comment 14 Sarantis Paskalis 2001-06-14 10:09:46 EDT
ok. Results shown below:
1) no xscreensaver, no control-center
(sarantis@gallagher)~$ xset q | grep -1 DPMS
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 60    Suspend: 120    Off: 180
  DPMS is Enabled
  Monitor is On

2) xscreensaver, no control-center
(sarantis@gallagher)~$ xset q | grep -1 DPMS
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 60    Suspend: 120    Off: 180
  DPMS is Enabled
  Monitor is On

3) no xscreensaver, control-center
(sarantis@gallagher)~$ xset q | grep -1 DPMS
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 1440
  DPMS is Enabled
  Monitor is On
(the 1440 value comes from the control-center settings:
 4min before screensaver + 20min before poweroff)

4) xscreensaver, control-center
(sarantis@gallagher)~$ xset q | grep -1 DPMS
 Bug Mode: compatibility mode is disabled
 DPMS (Energy Star):
   Standby: 7200    Suspend: 7200    Off: 14400
   DPMS is Disabled
 Font cache:

packages are:
XFree86-4.0.3-5
xscreensaver-3.32-2
control-center-1.4.0.1-3
Comment 15 Jeremy Sanders 2001-06-22 05:27:12 EDT
I get the same problem (on at least two machines). DPMS works, as if I do

xset +dpms

then run the gnome screensaver (with a lock button on my panel), the monitor
goes into standby after the period of time set in the control panel.

xset q shows:
DPMS (Energy Star):
  Standby: 10    Suspend: 10    Off: 10
  DPMS is Enabled
  Monitor is On

If I then run gnome control panel (the screen saver options), and do xset q, I get:
DPMS (Energy Star):
  Standby: 10    Suspend: 10    Off: 10
  DPMS is Disabled

I'm using (standard) RH7.1, and XFree86 4. No rawhide updates.

Comment 16 Bryce Nesbitt 2001-06-25 14:08:25 EDT
I have the same problem.  xset +dpms fixes it, but it should have just worked.
Comment 17 Sarantis Paskalis 2001-08-21 07:52:35 EDT
The bug is still present in Roswell (xscreensaver-3.32-4, control-center-1.4.0.1-9)
Comment 18 wdc 2001-10-12 00:15:00 EDT
*** Bug 54230 has been marked as a duplicate of this bug. ***
Comment 19 Craig Lawson 2001-10-27 14:42:52 EDT
I've been investigating this one, also. What I found:

* In my /etc/X11/XF86Config-4 file, my monitor was not configured to support
DPMS. Even though my previous XF86Config did not have this option set, it
apparently was not needed for DPMS to work correctly. It seems to me that the RH
7.1 upgrader did not catch this one. So I added it:
            Section "Monitor"
	      ...
	      Option  "DPMS"
            EndSection
but this did not solve the problem.

* Enabling "Use power management" in the Gnome Control Center does, according to
xset, not enable power management.

* Emabling power management directly with xset works as expected. But subsequent
fiddling with the "Use power management" option in the Gnome Control Center
disables DPMS.

* Enabling power management with the "Lock screen" applet does, according to
xset, correctly enable power management. And it also really works. The Lock
Screen applet also created a ~/.xscreensaver file with reasonable settings. This
file did not exist before (although xscreensaver and DPMS worked fine in RH 7.0
without this file). Subsequent fiddling with the "Use power management" option
from then on does not disable DPMS.

DPMS now works correctly on my system.

XFree86-4.0.3-5
xscreensaver-3.29-3
control-center-1.2.2-8

Note You need to log in before you can comment on or make changes to this bug.