Bug 40910 - printing should allow NUP and Banner options
Summary: printing should allow NUP and Banner options
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printconf   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 52539 62047 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-16 15:04 UTC by Jos Dehaes
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 15:59:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Dehaes 2001-05-16 15:04:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.4 i686)

Description of problem:
Printing more than one page on a single sheet doesnt work. There is no way
to enter this in the config tool. However, the definitions in
/var/spool/lpd/lp2up/postscript.cfg does say NUP=2, probably from RH7.0.
But printing to this printerqueue prints 1-up.

Also there is no way to choose a banner page (like in old printtool), and
also doesn't print

How reproducible:
Always

Steps to Reproduce:
1. print to lp2up queue
2.
3.
	

Actual Results:  printed 1-up without banner

Expected Results:  printed 2-up with banner

Additional info:

my /var/spool/lpd/lp2up/postscript.cfg


# configuration related to postscript printing
# generated automatically by PRINTTOOL
# manual changes to this file may be lost
#
GSDEVICE=POSTSCRIPT
RESOLUTION=1200x1200
COLOR=
PAPERSIZE=a4
EXTRA_GS_OPTIONS=""
REVERSE_ORDER=
PS_SEND_EOF=NO

#
# following is related to printing multiple pages per output page
#
NUP=2
RTLFTMAR=18
TOPBOTMAR=18



my printcap entry for this queue

lp2up:\
:sh:\
:ml=0:\
:mx=0:\
:sd=/var/spool/lpd/lp2up:\
:rm=tao:\
:rp=netprinter-54:\
:bk:\
:lpd_bounce=true:\
:if=/usr/share/printconf/mf_wrapper:

Comment 1 Tim Waugh 2002-03-06 13:34:19 UTC
*** Bug 52539 has been marked as a duplicate of this bug. ***

Comment 2 Tim Waugh 2002-04-02 09:04:37 UTC
*** Bug 62047 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2002-10-11 15:58:54 UTC
Fixed in CVS (finally!).

Comment 4 Tim Waugh 2002-10-16 12:35:09 UTC
redhat-config-printer-0.6.12 configures NUp and banner pages for CUPS.


Note You need to log in before you can comment on or make changes to this bug.