Bug 409231 - eclipse 3.3.0 fails to start
eclipse 3.3.0 fails to start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 15:06 EST by Petr Hrasky
Modified: 2007-12-03 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 17:09:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eclipse startup error logs (3.31 KB, application/x-tbz)
2007-12-03 15:06 EST, Petr Hrasky
no flags Details

  None (edit)
Description Petr Hrasky 2007-12-03 15:06:27 EST
Description of problem:

eclipse 3.3.0 fails to start with error and points to a log file - see 
attached files.

Version-Release number of selected component (if applicable):

eclipse 3.3.0 running Sun java 1.6u3 and jre 1.5_14

# rpm -q eclipse-platform
eclipse-platform-3.3.0-30.fc8
# rpm -q jdk
jdk-1.6.0_02-fcs
jdk-1.6.0_03-fcs
# rpm -q jre
jre-1.5.0_14-fcs


How reproducible:

allways

Steps to Reproduce:
1. start eclipse
2. click ok in dialog
3. 
  
Actual results:

failure to start - see logs

Expected results:

eclipse application gui coming up



Additional info:

Eclipse did run after upgrade to fc8, but there were some issues with qt and 
qtjambi plugins. So I uninstalled rpms for eclipse, 
deleted /usr/share/eclipse, /usr/lib/eclipse, .eclipse in my home and 
workplace dir. Then I reinstalled eclipse rpms for platform , cdt, jdt and 
dependencies. After that I get the error during startup.

I tried to use jdk 1.6u3 and jre 1.5 u14 with no change.
Comment 1 Petr Hrasky 2007-12-03 15:06:27 EST
Created attachment 276061 [details]
eclipse startup error logs
Comment 2 Andrew Overholt 2007-12-03 15:36:05 EST
Please send the output of the following:

for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm -qV $f; done

Comment 3 Petr Hrasky 2007-12-03 16:04:23 EST
Here is the output and it is interesting (to me at least)


# for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm -qV $f; done
eclipse-platform-3.3.0-30.fc8
.......T   /usr/bin/eclipse
eclipse-cdt-4.0.1-1.fc8
eclipse-rcp-3.3.0-30.fc8
libswt3-gtk2-3.3.0-30.fc8
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-atk-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-awt-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-cairo-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-glx-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-gnome-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-mozilla-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-pi-gtk-3346.so
missing     /usr/lib/eclipse/libswt-atk-gtk-3346.so
missing     /usr/lib/eclipse/libswt-awt-gtk-3346.so
missing     /usr/lib/eclipse/libswt-cairo-gtk-3346.so
missing     /usr/lib/eclipse/libswt-glx-gtk-3346.so
missing     /usr/lib/eclipse/libswt-gnome-gtk-3346.so
missing     /usr/lib/eclipse/libswt-gtk-3346.so
missing     /usr/lib/eclipse/libswt-mozilla-gtk-3346.so
missing     /usr/lib/eclipse/libswt-pi-gtk-3346.so
missing     /usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar
missing     /usr/lib/eclipse/swt-gtk-3.3.0.jar
missing     /usr/lib/eclipse/swt-gtk-3.3.jar
missing     /usr/lib/eclipse/swt.jar
eclipse-jdt-3.3.0-30.fc8
eclipse-cvs-client-3.3.0-30.fc8
eclipse-ecj-3.3.0-30.fc8
tomcat5-jasper-eclipse-5.5.25-1jpp.1.fc8
icu4j-eclipse-3.6.1-1jpp.3.fc8
#                             
Comment 4 Petr Hrasky 2007-12-03 16:05:38 EST
So it looks I wiped out bit too much? Any more checks or I can try to 
reinstall libswt3-gtk2-3.3.0-30.fc8?
Comment 5 Andrew Overholt 2007-12-03 16:18:18 EST
Yeah, it looks like swt is messed up.  Try re-installing it, re-running the
verification step, and then try starting up again.
Comment 6 Petr Hrasky 2007-12-03 16:44:00 EST
I reinstalled, run the script again:

eclipse-platform-3.3.0-30.fc8
.......T   /usr/bin/eclipse
eclipse-cdt-4.0.1-1.fc8
eclipse-rcp-3.3.0-30.fc8
eclipse-jdt-3.3.0-30.fc8
eclipse-cvs-client-3.3.0-30.fc8
eclipse-ecj-3.3.0-30.fc8
libswt3-gtk2-3.3.0-30.fc8
tomcat5-jasper-eclipse-5.5.25-1jpp.1.fc8
icu4j-eclipse-3.6.1-1jpp.3.fc8


and now it runs. Thanks for help. 
Comment 7 Andrew Overholt 2007-12-03 17:09:30 EST
No problem.  I'll close this but feel free to re-open if things break again.

Note You need to log in before you can comment on or make changes to this bug.