Bug 410211 - gnomesword2 libgtkembedmoz.so missing, no dependency in RPM
gnomesword2 libgtkembedmoz.so missing, no dependency in RPM
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnomesword (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 07:18 EST by Brent R Brian
Modified: 2007-12-04 09:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 09:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent R Brian 2007-12-04 07:18:57 EST
gnomesword2 must be missing a dependency in the RPM, this managed to get past
YUM and YUMEX.

$ gnomesword2
gnomesword2: error while loading shared libraries: libgtkembedmoz.so: cannot
open shared object file: No such file or directory

loading gtkembedmoz does not fix this problem.
Comment 1 Brent R Brian 2007-12-04 07:24:14 EST
$ locate gtkmozembed
/home/brent/.anjuta/tags/firefox-gtkmozembed.anjutatags.gz
/usr/include/firefox-2.0.0.10/gtkembedmoz/gtkmozembed.h
/usr/include/firefox-2.0.0.10/gtkembedmoz/gtkmozembed_internal.h
/usr/lib/pkgconfig/firefox-gtkmozembed.pc
/usr/share/pygtk/2.0/defs/gtkmozembed.defs
/usr/src/redhat/BUILD/mozilla/build/unix/mozilla-gtkmozembed.pc.in
/usr/src/redhat/BUILD/mozilla/build/unix/nvu-gtkmozembed.pc
/usr/src/redhat/BUILD/mozilla/embedding/browser/gtk/src/gtkmozembed.h
/usr/src/redhat/BUILD/mozilla/embedding/browser/gtk/src/gtkmozembed2.cpp
/usr/src/redhat/BUILD/mozilla/embedding/browser/gtk/src/gtkmozembed_internal.h
/usr/src/redhat/BUILD/mozilla/embedding/browser/gtk/src/gtkmozembedmarshal.c
/usr/src/redhat/BUILD/mozilla/embedding/browser/gtk/src/gtkmozembedmarshal.h
/usr/src/redhat/BUILD/mozilla/embedding/browser/gtk/src/gtkmozembedprivate.h
$ 


Comment 2 Deji Akingunola 2007-12-04 09:03:50 EST
This is caused by you having updated to later firefox version than gnomesword
was compiled with. I've already built a new gnomesword to go with
firefox-2.0.0.10, but its still waiting to be push to the stable updates, you
can grab it at
http://koji.fedoraproject.org/packages/gnomesword/2.3.1/2.fc8/i386/gnomesword-2.3.1-2.fc8.i386.rpm

Note You need to log in before you can comment on or make changes to this bug.