Bug 410281 - hts plan add results in a Python traceback
hts plan add results in a Python traceback
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 08:03 EST by Rainer Koenig
Modified: 2008-05-01 11:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 10:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2007-12-04 08:03:58 EST
Description of problem:
I want to add another video card to the test plan. By doing this I get a
traceback with errors from Python:

[root@v840 testsuite]# hts plan --add --test video --udi pci_10de_19d
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
Traceback (most recent call last):
  File "/usr/bin/hts", line 55, in ?
    success = hts.do(args)
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 151, in do
    return self.doPlan()
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 253, in doPlan
    self.addTest()
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 689, in addTest
    device = planner.getDeviceByUDI(self.options.udi)
  File "/usr/share/hts/lib/hts/planner.py", line 138, in getDeviceByUDI
    if udi in device.getUDI():
TypeError: 'in <string>' requires string as left operand
[root@v840 testsuite]#

Version-Release number of selected component (if applicable):
This happens with hts-5.1.16.el5.noarch.rpm 

How reproducible:
Always.

Steps to Reproduce:
See above.
  
Actual results:
Python traceback

Expected results:
No error messages. :-)

Additional info:
This was an issue during hts development before. I guess it got fixed but now
with the -16 release it seems to be back. :-(
Comment 1 Greg Nichols 2007-12-04 09:27:40 EST
Fix in R17
Comment 3 Satyabrata Maitra 2007-12-17 02:19:34 EST
Tested this bug in i386 arch with the following result shown in g-t.

********
hts plan --add --test video --udi pci_10de_19d
Hardware: Dell Computer Corporation unknown PowerEdge 700
OS: Tikanga 5.1
saved configuration to /var/hts/config.xml
OS Version RHEL5, kernel rpm kernel-2.6.18-53.el5
HTS version 5.1, release 18
Created a new plan with 10 tests on 74 devices
Warning: unknown device: pci_10de_19d 
OS Version RHEL5, kernel rpm kernel-2.6.18-53.el5
HTS version 5.1, release 18
Added test
saved test plan to /var/hts/plan.xml

*****************

Version of the component tested :-
hts-5.1-18.el5
RHEL5.1-Server

No traceback given during the test. This bug is fixed in the tested version of hts.

Note You need to log in before you can comment on or make changes to this bug.