Bug 410351 - DBG patch for DDD urgently needed
DBG patch for DDD urgently needed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ddd (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 08:24 EST by Keith Roberts
Modified: 2007-12-11 15:09 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 14:10:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Notes on configuring DBG module, Xdebug module, and ProtoEditor (2.61 KB, application/octet-stream)
2007-12-07 09:36 EST, Keith Roberts
no flags Details

  None (edit)
Description Keith Roberts 2007-12-04 08:24:23 EST
feature request (IMHO *urgent*:

I'm bashing my head against a  brick wall trying to get PHPEclipse plugin 
working with DBG php debugger module.

I see there is a dbg patch for ddd that will allow ddd to communicate with the 
dbg-5.2.x.so php extension. Please can we have ddd compiled with the dgb patch 
to allow PHP debugging with ddd?

Here are the links to the ddd-dbg path files, and source ddd-dbg rpms:

http://sourceforge.net/project/showfiles.php?group_id=33454

I'm even trying to compile ddd+dbg myself, that's how desperate I am to get a 
decent PHP debugger working!
Comment 1 Tom "spot" Callaway 2007-12-06 18:14:31 EST
I'll look into this next week, I'm in India at the moment.
Comment 2 Keith Roberts 2007-12-07 09:36:30 EST
Created attachment 281241 [details]
Notes on configuring DBG module, Xdebug module, and ProtoEditor
Comment 3 Keith Roberts 2007-12-07 09:39:49 EST
Thanks Tom. Since posting this request I have found a nice PHP debugger that
works on sourceforge.

https://sourceforge.net/project/screenshots.php?group_id=129439

I downloaded and installed protoeditor-1.1beta3-1.i386.rpm. It required one
compat package.

I have added an attachment documenting configuring ProtoEditor, DBG and 
Xdebug PHP modules.

It seems the problem with setting up DBG was a missing option in php.ini:

debugger.ports = 7869, 10000/16

This option is not listed in the output of phpinfo, but is vital for getting DBG
working.

As well as the patch for ddd, maybe we could have the Kate ProtoEditor plugin
added to Fedora 8 please?

The Xdebug module has always worked for me. release 2.0.2-dev supports three
debugging protocols:

xdebug
xdebug support	enabled
Version 	2.0.2-dev

Supported protocols	           Revision
DBGp - Common DeBuGger Protocol    $Revision: 1.125 $
GDB -  GNU Debugger protocol 	   $Revision: 1.87 $
PHP3 - PHP 3 Debugger protocol 	   $Revision: 1.22 $

The DBG module has a bug that will not allow it to work with the CLI version of
PHP locally. Xdebug does not have this problem. You can even use the Xdebug
module to debug PHP scripts locally, via PHP CLI interpreter, or remotely, using
either the Xdebug protocol, or the DBG protocol. So it may be possible to use
Xdebug as a stand-in for the DBG module with Eclipse? Something I need to check
out ASAP.
Comment 4 Keith Roberts 2007-12-07 09:43:56 EST
ProtoEditor website: http://protoeditor.sourceforge.net/

Comment 5 Tom "spot" Callaway 2007-12-11 14:10:53 EST
You should file a new bug against kate for the protoeditor stuff.

Also, the DBG support went into upstream DDD a while ago, those patches are no
longer necessary, the Fedora ddd package supports DBG out of the box.
Comment 6 Keith Roberts 2007-12-11 15:09:22 EST
Thankyou for mentioning that Tom. Looking at the RPM description of DDD (in
Smart) there is no mention of DBG support in DDD, which is why I filled this
request. Maybe the RPM package description can be updated to tell others that
DBG support is now built-in to DDD? And also that the DBG client may work with
the xdebug php module?


Note You need to log in before you can comment on or make changes to this bug.