This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 410441 - 3.0.24-9.fc6 is broken
3.0.24-9.fc6 is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
6
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
: 416151 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 09:41 EST by Nerijus Baliūnas
Modified: 2007-12-08 09:25 EST (History)
2 users (show)

See Also:
Fixed In Version: samba-3.0.24-11.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 09:16:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2007-12-04 09:41:58 EST
Latest update is broken - some files are not seen from XP clients (permissions
are ok, files are accessible from linux console). Downgrading to 3.0.24-8.fc6
helps. Happens both on i386 and x86_64.
Comment 1 Michael Weidner 2007-12-04 10:13:11 EST
Same Problem here, seems to happen if there are many files in the directory.
Also on i386 and X86_64. Also downgrade solves the problem.
Comment 2 Michael J. Chudobiak 2007-12-04 10:15:07 EST
Same problem here!

For instance, I have one shared folder with 1065 files. Only 115 of these are
shown when browsing from Windows 2000. When browsing the samba share from
Nautilus, I see ~500 files. When browsing the same directory via NFS, I see all
1065 files.

The file permissions are correct. Selinux is disabled.

Something appears to have broken in the smb server.

The log files are not yielding any useful clues.
Comment 3 Simo Sorce 2007-12-04 10:18:51 EST
Can you check if you see anything in the logs?
Comment 4 Michael Weidner 2007-12-04 10:26:00 EST
(In reply to comment #3)
> Can you check if you see anything in the logs?
> 

There are no errors or unusal messages in the logs (with standard debug level).
Comment 5 Nerijus Baliūnas 2007-12-04 10:33:42 EST
No unusual messages too, but there are only 393 files and 3 dirs in affected
directory.
Comment 6 Simo Sorce 2007-12-04 12:17:28 EST
I have a fix, building packages right now.
Comment 7 zekkerj 2007-12-04 16:27:17 EST
Same here. Seems that the number of files in the dir is the key to the problem
(when there is more than about 120 files, some of them are not listed, but are
still accessible).

I also got no error message, log level = 3.

I downgraded to samba 3.0.24-7 and the problem disappeared.
Comment 8 Michael Weidner 2007-12-05 02:29:00 EST
(In reply to comment #6)
> I have a fix, building packages right now.

The new package (samba-3.0.24-11.fc6) solves the problem for me (x86_64 and i386).
Comment 9 Michael J. Chudobiak 2007-12-05 08:21:04 EST
samba-3.0.24-11.fc6 works for me too, now.

- Mike
Comment 10 Simo Sorce 2007-12-08 09:25:43 EST
*** Bug 416151 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.