Bug 41052 - Adding tcp wrappers to vnc.
Adding tcp wrappers to vnc.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
http://www.uk.research.att.com/vnc/ex...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 01:25 EDT by Ian Mortimer
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 06:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds tcp wrappers support to vnc (3.89 KB, patch)
2001-05-17 01:26 EDT, Ian Mortimer
no flags Details | Diff

  None (edit)
Description Ian Mortimer 2001-05-17 01:25:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Vnc is one of the few network services not protected by tcpd.   Wolfram
Gloger has
provided a patch to fix that..  I've attached it below.

How reproducible:
Always

Steps to Reproduce:
1.Not applicable
2.
3.
	

Additional info:

You have to specify ip numbers in hosts.allow.  Domains or host names won't
work.

The patch doesn't add libwrap to the linking phase.  You need to make this
patch to vnc.spec:

*** vnc.spec    2001/05/17 05:25:17     1.2
--- vnc.spec    2001/05/17 04:57:35
***************
*** 17,22 ****
--- 17,23 ----
  Patch2:    vnc-xauth.patch
  Patch3:    vnc-typo.patch
  Patch4:    vnc-corre.patch
+ Patch5:    %{name}-%{version}-tcpwrappers.patch
  License:   GPL
  Group:     User Interface/Desktops
  BuildRoot: %{_tmppath}/%{name}-%{version}-root
***************
*** 59,64 ****
--- 60,66 ----
  %patch2 -p1 -b .xauth
  %patch3 -p1 -b .typo
  %patch4 -p1 -b .corre
+ %patch5 -p1 -b .tcpwrappers
 
  find . -name "*,v" -exec rm -f {} \;
  perl -pi -e "s|/usr/local/vnc/classes|%{_datadir}/vnc/classes|" vncserver
***************
*** 67,73 ****
  xmkmf -a
  make CDEBUGFLAGS="$RPM_OPT_FLAGS" World
  cd Xvnc
! make CDEBUGFLAGS="$RPM_OPT_FLAGS" World
 
  %install
  rm -rf %{buildroot}
--- 69,75 ----
  xmkmf -a
  make CDEBUGFLAGS="$RPM_OPT_FLAGS" World
  cd Xvnc
! make EXTRA_LIBRARIES='-lwrap -lnss_nis' CDEBUGFLAGS="$RPM_OPT_FLAGS"
World
 
  %install
  rm -rf %{buildroot}
Comment 1 Ian Mortimer 2001-05-17 01:26:33 EDT
Created attachment 18711 [details]
Adds tcp wrappers support to vnc
Comment 2 Tim Waugh 2001-05-18 06:39:27 EDT
Thanks.  Yes, this looks like a good idea.
Comment 3 Tim Waugh 2001-06-05 09:18:50 EDT
Applied in 3.3.3r2-16.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.