Bug 41073 - IP packets have been lost when only 20 POP clients access at same time.
Summary: IP packets have been lost when only 20 POP clients access at same time.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 09:20 UTC by Keiichi Mori
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 03:06:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (420 bytes, patch)
2001-05-17 11:14 UTC, Arjan van de Ven
no flags Details | Diff

Description Keiichi Mori 2001-05-17 09:20:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.7) Gecko/20010316

Description of problem:
When 20 POP clients using "telnet <server></server> 110" and "expect"
access to at same time, xinetd can not fork only 18 process. Because
select() function in xinetd main_loop() catch the changed status at 110
port, only 18 times.

Packet dump by "ethereal" on POP Server is here:(station100 is a POP
Server, station67 is a POP Client)

    732 1.830000    station64  station100  TCP      32775 > pop3 [SYN]
Seq=3399523946 Ack=0 Win=5840 Len=0
    733 1.830000    station100 station64   TCP      pop3 > 32775 [SYN, ACK]
Seq=3802504036 Ack=3399523947 Win=5792 Len=0
!   750 1.830000    station64  station100  TCP      32775 > pop3 [ACK]
Seq=3399523947 Ack=3802504037 Win=5840 Len=0

* 18084 5.430000    station100 station64   TCP      pop3 > 32775 [SYN, ACK]
Seq=3802504036 Ack=3399523947 Win=5792 Len=0
* 22351 11.430000   station100 station64   TCP      pop3 > 32775 [SYN, ACK]
Seq=3802504036 Ack=3399523947 Win=5792 Len=0


Response to [SYN,ACK] reached the Link layer. But It seems not to reached
the Transport layer.

I think packet have been lost in Network layer.

Only 20 clients accessed, why packet have been lost?






How reproducible:
Always

Steps to Reproduce:
1.20 POP clients access to POP server at same time.(very critical)
2.
3.
	

Additional info:

Comment 1 Arjan van de Ven 2001-05-17 09:24:14 UTC
Dave: Could you take a look ?

Comment 2 Arjan van de Ven 2001-05-17 09:45:53 UTC
kmori@redhat.com: are you in a position to test a patch ?

Comment 3 Keiichi Mori 2001-05-17 10:57:39 UTC
I am not in development team, I am in service team.
But if you give me a patch, I'll test it.


Comment 4 Arjan van de Ven 2001-05-17 11:14:07 UTC
Created attachment 18732 [details]
Proposed patch

Comment 5 Keiichi Mori 2001-05-21 03:06:07 UTC
Thank you for creating attachment. I could get a patch.
I tested this patch, however, kernel had still lost packets.


Comment 6 Keiichi Mori 2001-05-22 07:37:34 UTC
This problem is caused by xinetd specification.

Because listen() backlog value defined by xinetd is low,
kernel drop client's requests.




Note You need to log in before you can comment on or make changes to this bug.