Bug 410791 - e2fsprogs-devel should require device-mapper-devel
e2fsprogs-devel should require device-mapper-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 13:08 EST by Stepan Kasal
Modified: 2007-12-06 23:11 EST (History)
2 users (show)

See Also:
Fixed In Version: e2fsprogs-1.40.2-13.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 23:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2007-12-04 13:08:11 EST
The blkid.pc specifies that devmapper is a prerequisite of blkid.
Consequently, if devmapper.pc is not available, the pkg-config program errs out.
So it is necesary that the rpm dependencies reflect the dependencies in the
pkg-config descriptions.
In this case, it means that e2fsprogs-devel has to "Require: device-mapper-devel
>= 1.02.02-3".  (The pkg-config support was added in that version.)

Note You need to log in before you can comment on or make changes to this bug.