Bug 41093 - XFree86 cause core dumps on remote X aps trying to display on local X-server
XFree86 cause core dumps on remote X aps trying to display on local X-server
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 08:43 EDT by Frederik Strydom
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 08:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frederik Strydom 2001-05-17 08:43:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla

Description of problem:
CDE aps on Sun Solaris, like swmtool and admintool crash and then core 
dump, then the display enviroment variable is set on the remote Solaris 
server, to the display of the local RH7.1 Workstastion. Note that 
openwindows aps still works.

How reproducible:
Always

Steps to Reproduce:
1.telnet to Solaris server and login
2.Type in telnet term at prompt: DISPLAY=RH7_1WORKSTATION:0.0; export 
DISPLAY
3.On the local workstation type at prompt on term: xhost +RH7_1WORKSTATION
4.In the telnet term of the remote host (Solaris) type at prompt: anmintool
5.You can try swmtool as well.
6.Core dump on remote host and application exits.

	

Actual Results:  Core dump on remote host and application exits.
This means that I can't run any remote CDE integrated aps and display the 
output on the local X-server XFree86-4.0.3


Expected Results:  Application opens application window on local 
Workstation (or X-server).

Additional info:

This was not a problem with RH7, but there was a problem with some EMC-
Symetrix software, were the right button did not function properly, this 
was with XFree86-4.0.1 I think. Note that this problem did not exist on 
RH6.2, with XFree86-3.X
Comment 1 Mike A. Harris 2001-05-19 10:46:01 EDT
If the applications are core dumping in Solaris, then it is a bug in the
applications running on Solaris, not a bug in XFree86.  Most likely some
poor assumptions in the applications in Solaris, are no longer being met
with the newer XFree86.  Since this involves applications I do not have
in an OS I do not have or have access to, you would need to debug this
yourself and provide direct evidence of a bug in our XFree86 before I
could do anything about it if it were a bug in XFree86 anyway.  If you do
trace the problem back to an XFree86 bug, that can be reproduced with
a small sample program of some sort, then we can consider it a bug in
XFree86.

Note You need to log in before you can comment on or make changes to this bug.