Bug 41113 - Problem with gnorpm upgrade
Summary: Problem with gnorpm upgrade
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 16:08 UTC by Giox
Modified: 2007-04-18 16:33 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-05-17 16:08:51 UTC


Attachments (Terms of Use)

Description Giox 2001-05-17 16:08:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.12-20 i686)

Description of problem:
After upgrading RPM to version rpm-4.0.2-6x i have tryed to upgrade gnorpm:
        rpm -Fvh gnorpm-0.95.1-6.6x.i386.rpm
but i recive the following message:
        error: failed dependencies: /etc/pam.d/system-auth is needed by
                                              gnorpm-0.95.1-6.6x
When I try to use gnorpm i get the following error:
error in loading shared libraries: /usr/lib/librpm.so.0: undefined symbol:
ufdio

How reproducible:
Always

Steps to Reproduce:
1.Upgrade RPM to version 4.0.2-6x
2.Try to upgrade gnorpm to version 0.95.1-6.6x
3.
	

Additional info:

Comment 1 Jeff Johnson 2001-05-21 13:23:14 UTC
The file /etc/pam.d/system-auth should be in the pam-0.72-20.6.x package.

Yes, you will see the undefined symbol if you use the old gnorpm, that's
what the new package fixes. Upgrade gnorpm from the command line.


Note You need to log in before you can comment on or make changes to this bug.