Bug 411261 - [RHEL5] [RFE] Need kernel modules for wanPCI-1T1E1LP hardware
[RHEL5] [RFE] Need kernel modules for wanPCI-1T1E1LP hardware
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.1
i686 Linux
low Severity medium
: ---
: ---
Assigned To: RHEL Product and Program Management
Ondrej Hudlicky
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 18:39 EST by Robert M Beers
Modified: 2012-10-25 03:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 03:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifup-hdlc for wanPCI-1T1E1LP (2.66 KB, text/plain)
2010-03-19 09:28 EDT, Robert M Beers
no flags Details
ifup-pvc for wanPCI-1T1E1LP (1.07 KB, text/plain)
2010-03-19 09:38 EDT, Robert M Beers
no flags Details

  None (edit)
Description Robert M Beers 2007-12-04 18:39:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Description of problem:
This card wanPCI-1T1E1LP
(ex: <http://www.onestopsystems.com/communication_wan_a.html>)
 has modules available in the kernel source which should allow for
 it's use -- if they were only included in the kernel rpm.

Necessary modules are hdlc, dlci, fr, syncppp, and lmc.
Necessary utilities are sethdlc and optional lmcctl.
Also needed are corresponding ifup and ifdown for -hdlc and -pvc,
 (I can provide my version of these scripts if desired), which
 read from ifcfg-hdlcX and ifcfg-pvcX config files.

Here is lspci -vxx info about the card:

01:05.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [FasterNet] (rev 22)
        Subsystem: LMC Unknown device 0006
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at d000 [size=128]
        Memory at e8201000 (32-bit, non-prefetchable) [size=128]
        [virtual] Expansion ROM at 48100000 [disabled] [size=256K]
00: 11 10 09 00 07 00 80 02 22 00 00 02 08 20 00 00
10: 01 d0 00 00 00 10 20 e8 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 76 13 06 00
30: 00 00 00 00 00 00 00 00 00 00 00 00 09 01 14 28


Version-Release number of selected component (if applicable):
kernel-2.6.18-53.1.4.el5

How reproducible:
Always


Steps to Reproduce:
1.modprobe lmc
2.modprobe hdlc
3.

Actual Results:
FATAL: Module lmc not found
FATAL: Module hdlc not found

Expected Results:
Modules should load.

Additional info:
There are actually a lot of installations where a RHEL server could
 be utilized if these drivers were available.

A separate rpm with just these kernel modules for the
 proveded kernel would be a workable alternative, but I
 understand that kmod or kmdl rpms are out of favor.
Comment 3 Anton Arapov 2010-02-10 06:29:31 EST
CLOSED as WONTFIX due to lack of the answer from the requester. Feel free to reopen the issue if needed, and please provide more input.
Thanks,
Comment 4 Robert M Beers 2010-02-10 11:13:39 EST
(In reply to comment #3)
> CLOSED as WONTFIX due to lack of the answer from the requester. Feel free to
> reopen the issue if needed, and please provide more input.
> Thanks,    

What !?  What answer are you missing?  Where is the question?

Where are comments #1 and #2?  I click on "expand all comments" above
 and still don't see them.  ???

baffled,
Comment 5 Andy Gospodarek 2010-02-10 12:10:27 EST
(In reply to comment #4)
> (In reply to comment #3)
> > CLOSED as WONTFIX due to lack of the answer from the requester. Feel free to
> > reopen the issue if needed, and please provide more input.
> > Thanks,    
> 
> What !?  What answer are you missing?  Where is the question?
> 
> Where are comments #1 and #2?  I click on "expand all comments" above
>  and still don't see them.  ???
> 
> baffled,    

Robert, I'm not completely sure why this was closed either.  I'll reopen it, and we can discuss a few things to help us understand your requirements a bit better.

The device you have appears to be supported by the driver build when enabling the CONFIG_LANMEDIA option that will become available when CONFIG_WAN=y.  The subdevice ids from your system appear to be supported in the RHEL5 sources, but we do not have them available right now.

Is enabling these drivers in the config and rebuilding sufficient to get the support you need in RHEL5?
Comment 6 Robert M Beers 2010-02-10 16:02:19 EST
(In reply to comment #5)
> (In reply to comment #4)
> Robert, I'm not completely sure why this was closed either.  I'll reopen it,
> and we can discuss a few things to help us understand your requirements a bit
> better.
> 
> The device you have appears to be supported by the driver build when enabling
> the CONFIG_LANMEDIA option that will become available when CONFIG_WAN=y.  The
> subdevice ids from your system appear to be supported in the RHEL5 sources, but
> we do not have them available right now.
> 
> Is enabling these drivers in the config and rebuilding sufficient to get the
> support you need in RHEL5?    

Hi Andy,

No, as I mentioned in the original description:

Necessary utilities are sethdlc and lmcctl.
Also needed are ifup* and ifdown* for -hdlc and -pvc.
I have my own version of these network-scripts, which utilize
 ifcfg-hdlcX and ifcfg-pvcX config files in the same manner as
 ifup-eth and ifdown-eth utilize ifcfg-ethX config files.
Should I attach them here?
Comment 8 Linda Wang 2010-03-17 09:53:13 EDT
(In reply to comment#6)

> Necessary utilities are sethdlc and lmcctl.
> Also needed are ifup* and ifdown* for -hdlc and -pvc.
> I have my own version of these network-scripts, which utilize
>  ifcfg-hdlcX and ifcfg-pvcX config files in the same manner as
>  ifup-eth and ifdown-eth utilize ifcfg-ethX config files.
> Should I attach them here?   

Yes, please. This will help us to understand your request better.
Also, please work with our support team to get your feature request
in. Many thanks!
Comment 9 Robert M Beers 2010-03-19 09:28:28 EDT
Created attachment 401246 [details]
ifup-hdlc for wanPCI-1T1E1LP

When hdlc, dlci, syncppp, and lmc kernel modules are compiled,
 I use the attached ifup-hdlc and ifup-pvc scripts to enable
 the hardware similarly to how other devices are enabled using
 /etc/sysconfig/network-scripts/*.
Comment 10 Robert M Beers 2010-03-19 09:38:41 EDT
Created attachment 401249 [details]
ifup-pvc for wanPCI-1T1E1LP

for frame-relay DLCI sub-interfaces.
Comment 14 RHEL Product and Program Management 2010-08-09 14:16:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 RHEL Product and Program Management 2012-10-10 07:48:59 EDT
Thank you for submitting this issue for consideration. Red Hat Enterprise Linux 5 has reached the end of Production 1 Phase of its Life Cycle.  Red Hat does not plan to incorporate the suggested capability in a future Red Hat Enterprise Linux 5 minor release. If you would like Red  Hat to re-consider this feature request and the requested functionality is not currently in Red Hat Enterprise Linux 6, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.