Bug 411411 - Activating VPN connection causes nm-applet to die
Activating VPN connection causes nm-applet to die
Status: CLOSED DUPLICATE of bug 409351
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 20:55 EST by Dan Poler
Modified: 2007-12-05 03:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 03:02:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Poler 2007-12-04 20:55:53 EST
Description of problem:
As the summary says - pulled down the new NetworkManager update today;
activating a (vpnc) VPN connection causes nm-applet to tank (although the rest
of NetworkManager does appear to keep running. 

Version-Release number of selected component (if applicable): 
$ rpm -qa|grep NetworkManager
NetworkManager-gnome-0.7.0-0.6.6.svn3109.fc8
NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-0.7.0-0.6.6.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3109.fc8


How reproducible:
Always

Steps to Reproduce:
1. Click on NetworkManager icon in GNOME
2. Navigate to VPN Connections
3. Activate a VPN Connection; nm-applet will crash
  
Actual results:
If nm-applet is started from a terminal, the messages under "Additional info"
are logged, and nm-applet dies.

Expected results:
VPN connection should have started.

Additional info:

** (nm-applet:3665): WARNING **: nm_object_get_property: Error getting 'Name'
for /org/freedesktop/NetworkManager/VPN/Connection/1: Method "Get" with
signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist



** (nm-applet:3665): WARNING **: nm_object_get_property: Error getting 'Name'
for /org/freedesktop/NetworkManager/VPN/Connection/1: Method "Get" with
signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist


04d5fbd7-c8ef-52d9-0fe0e14e-12fdd863 is dumped
Comment 1 Denis Leroy 2007-12-05 03:02:14 EST

*** This bug has been marked as a duplicate of 409351 ***

Note You need to log in before you can comment on or make changes to this bug.