Bug 41172 - Need a single-disk PCMCIA install.
Need a single-disk PCMCIA install.
Status: CLOSED DUPLICATE of bug 39029
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
All Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 20:19 EDT by Steve Kann
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 18:10:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Kann 2001-05-17 20:19:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-8 i686; en-US; rv:0.9)
Gecko/20010507

Description of problem:
Many subnotebooks these days come with no internal floppy or CD-rom drive.
 In particular, this affects Sony Picturebooks.

The external units for floppies, use a USB interface.  The CD-Roms are
expensive (I don't have one).

In previous versions of RHL, I could use the PCMCIA boot disk, and then
install via a network card.  Now, however, that is impossible, because the
boot disk (#1) doesn't understand usb-storage in order to load boot disk (#2).

My other alternative was to put the ISO images on my hard disk, but there's
only a 2GB disk there, and there's no way to make 1.3GB free for TWO iso
images!

So, I've been able to keep updating this machine from 5.2 through 7.0, but
now I'm quite in a hole trying to get to 7.1.

The solutions for subnotebooks like this would be either:

(1) A single-disk PCMCIA boot (with common network card drivers, i.e.
3c589, etc) included,
or 
(2) usb-storage support in the first disk.

usb-storage works dandy with this floppy, BTW.



How reproducible:
Always

Steps to Reproduce:
1.Try to install or upgrade RHL on a subnotebook with a floppy, but no
2.bootable CD-ROM.
3.It won't work.


Additional info:
Comment 1 Steve Kann 2001-05-17 20:57:58 EDT
I've solved my own problem here:  It seems that I've found the one path through
the puzzle:

I copied the dosutils directory from the CD-rom (via older linux install), to
the dos partition on this machine, and then ran autoboot.  Found that the images
there do include PCMCIA support, and now I'm proceeding with a network upgrade.

So, maybe another lost soul will find this helpful, even if RH decides not to
make a single-disk PCMCIA install.  (probably what will be more necessary is to
support USB floppies for non-legacy systems..).

I'll leave the status here as new, and let the RH guys decide if they want to
just close this.

-SK
Comment 2 Brent Fox 2001-05-18 15:22:21 EDT
Why can't you use the two laptop boot disks?  pcmcia.img to boot from, and then
pcmciadd.img to pull in things like the network drivers.
Comment 3 Steve Kann 2001-05-18 16:02:15 EDT
I thought this was clear from my original description.

The laptop has no internal floppy drive, only an external USB floppy drive (A
relabeled Y-E data unit).

After using the first PCMCIA boot disk, the installer asks for the second disk,
but is unable to read the disk, because the USB-storage modules, etc., for the
floppy drive are not loaded.

The first disk works OK, because the BIOS supports the floppy drive.  Once Linux
boots, however, those BIOS routines are unavailable, and one would need to have
USB support set-up at that time in order to read the disk.

Comment 4 Brent Fox 2001-05-21 11:56:21 EDT
ewt, I don't think we supported USB pcmcia installs with 7.1.  Am I right on
that?  I don't think there was room on the boot floppy.
Comment 5 Brent Fox 2001-05-31 11:02:57 EDT
We don't support USB installs with 7.1 on pcmcia systems.  This is because there
isn't room on the first disk for the USB drivers.  This is a problem that we are
working on, because I think more people are running into this problem as more
people install Red Hat Linux on laptop systems.  It will probably involve
putting together another boot disk.  There's just so little room for drivers on
the floppies, especially since the 2.4 kernel takes up more room than 2.2.x did.
Comment 6 Brent Fox 2001-06-26 18:10:05 EDT

*** This bug has been marked as a duplicate of 39029 ***

Note You need to log in before you can comment on or make changes to this bug.