Bug 41189 - exmh inc.expect script doesn't work as advertised
exmh inc.expect script doesn't work as advertised
Product: Red Hat Linux
Classification: Retired
Component: exmh (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-05-17 21:23 EDT by Ian Mortimer
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-17 21:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix inc.expect (and ftp.expect) from exmh-2.3.1 (2.75 KB, patch)
2001-05-17 21:26 EDT, Ian Mortimer
no flags Details | Diff

  None (edit)
Description Ian Mortimer 2001-05-17 21:23:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
exmh is supposed to be able to retrieve mail from a pop server.  In the
absence of a .netrc file it prompts for a password and uses inc.expect to
login to the pop server.  The inc.expect script if faulty so this doesn't

How reproducible:

Steps to Reproduce:
1.Configure exmh to use pop (Preferences menu)
2.Click on inc
3.Password prompt comes up - enter password (and username if needed)


Actual Results:  No mail is retrieved.  Logs on the pop server don't record
any connection attempt

Expected Results:  The pop server should have been contacted and Mail

Additional info:

exmh depends on nmh.  nmh distributed with RH 7.1 won't fetch mail from a
pop server
unless it is patched as described in bug #41170.  However with that patch
applied exmh 
still doesn't get mail from the pop server even though inc from the command
line works fine.

The problem is with inc.expect.  The inc.expect from exmh-2.4 works but
exmh-2.4 itself doesn't work with RH 7.1.  It looks like an upgrade of
Tcl/Tk might be needed to get it to work but I didn't investigate further.

Anyway the solution is to get inc.expect from exmh-2.4 or apply the
attached patch to inc.expect from exmh-2.3.1 (to achieve the same result).
Comment 1 Ian Mortimer 2001-05-17 21:26:02 EDT
Created attachment 18850 [details]
Patch to fix inc.expect (and ftp.expect) from exmh-2.3.1

Note You need to log in before you can comment on or make changes to this bug.