Bug 411941 - java-1.7.0-icedtea should require jpackage-utils-1.7.3-1jpp.3
java-1.7.0-icedtea should require jpackage-utils-1.7.3-1jpp.3
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-05 08:49 EST by Joachim Selke
Modified: 2008-01-03 12:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-03 12:59:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Selke 2007-12-05 08:49:25 EST
I have a F7 system running and installed java-1.7.0-icedtea using the rawhide
RPMs (version I can use Icedtea java as such
without any problems but some applications like ant refuse to run anymore.

When executing "ant" I get the following:

Exception in thread "main" java.lang.NoClassDefFoundError:
Caused by: java.lang.ClassNotFoundException: org.apache.tools.ant.launch.Launcher
        at java.net.URLClassLoader$1.run(URLClassLoader.java:220)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:208)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
Error: Could not find the main class.
Error: A JNI error has occurred, please check your installation and try again

I get this error because on my system an old version of jpackage-utils was
installed (version jpackage-utils-1.7.3-1jpp.2). When I updated to version
jpackage-utils-1.7.3-1jpp.3 the problem was solved.

It seems that some applications need jpackage-utils >= 1.7.3-1jpp.3 if Icedtea
java is used.

Solution: I suggest to add jpackage-utils >= 1.7.3-1jpp.3 as a dependency to the
java-1.7.0-icedtea RPM.
Comment 1 Lillian Angel 2007-12-13 10:45:11 EST
This will be fixed in the next release.
Comment 2 Lillian Angel 2008-01-03 12:59:52 EST
Should be available in rawhide within the next couple of days.

Note You need to log in before you can comment on or make changes to this bug.