Bug 41197 - System freezes completely
System freezes completely
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 00:44 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -v outut (2.00 KB, text/plain)
2001-05-18 08:59 EDT, Bernhard Ege
no flags Details
The output from lspci -v executed by root (2.08 KB, text/plain)
2001-05-20 00:30 EDT, Need Real Name
no flags Details
Output from command: lspci -v (1.64 KB, text/plain)
2001-05-23 10:09 EDT, Need Real Name
no flags Details
output of lscpi -v (from root) (2.71 KB, text/plain)
2001-07-12 09:58 EDT, Mauro Innocenti
no flags Details

  None (edit)
Description Need Real Name 2001-05-18 00:44:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:
System freezes completely when working with network (mounting nfs/smb
filesystems or working from xdm session from remote NCD)

How reproducible:
Always

Steps to Reproduce:
1. Boot the system
2. login with KDE session
3. mount smb network drive (from NT server)
4. Copy some files from/to smb drive

Actual Results:  System freezes completely - mouse pointer not moves,
keyboard not responses (pressing <Num Lock> not leds).
telnet/ftp/xdm not accepts login from network

Additional info:

I have upgraded from Red Hat 6.1 to 7.1.
Updated all available packages in updates site.
My considuration that the kernel is source of the problem is based on
temporary solution I found:
Installing rpm of old kernel-2.2.14-5.0 and configuring lilo to boot the
old and the new one. With old kernel system works fine and stable.
Comment 1 Arjan van de Ven 2001-05-18 04:12:53 EDT
Ok. What networkcard do you have ?
Could you give me the output of "lspci -v", this will give me more information
about what your system is.
Comment 2 Bernhard Ege 2001-05-18 08:58:11 EDT
I have also seen the kernel crash this way with smbmounts. I am not using xdm
and can therefore not comment on that. This has appened with kernel 2.2.16-22,
kernel 2.4.2-2 and now 2.4.3-2.14.14. lspci -v info attached below.
Comment 3 Bernhard Ege 2001-05-18 08:59:31 EDT
Created attachment 18910 [details]
lspci -v outut
Comment 4 Arjan van de Ven 2001-05-18 09:01:49 EDT
bme@vision.auc.dk: are you using the nvidia module by chance ?
Comment 5 Bernhard Ege 2001-05-18 09:08:53 EDT
Yes, I am (version 0.9-769). Is this a know problem then? My has otherwise been
stable, although just yesterday I discovered running wine/winamp (on remote
display, X not started) or java (j2v1.30) completely freezes my machine. I am
using 2.4.3-2.14.14 as found on rawhide.
Comment 6 Arjan van de Ven 2001-05-18 09:13:31 EDT
Using the propriatry NVidia driver causes a lot of problems; it seems they 
overwrite random bits of kernelmemory. Please take any bugreports while having
the driver loaded (or having unloaded the driver but not rebooted) to NVidia,
not us.
Comment 7 Need Real Name 2001-05-20 00:30:13 EDT
Created attachment 19050 [details]
The output from lspci -v executed by root
Comment 8 Need Real Name 2001-05-20 00:35:52 EDT
On same machine hardware and configuration
(server for: xdm,nfs,samba,news,http,pop3,bootp,dns)
was running stable without freezes or crashes for months RedHat 5.2, 6.1
and now 7.1 - just with older (from 6.2 system) kernel.
Comment 9 Bernhard Ege 2001-05-20 05:28:25 EDT
When I ran wine/winamp I did exactly that, i.e. not having started the nvidia
driver ever since boot. The kernel crashed without the nvidia module ever having
been loaded (X/nv not running). The wine/winamp combo caused the crash.
wine/winamp worked completely normal until the kernel crashed (with no console
output what so ever. Sudden death I would call it). I tried with the builtin
ymfpci/ac97_codec module as well as the alsasound system. xmms nor mpg123 caused
any crashes.
Comment 10 Need Real Name 2001-05-23 10:09:14 EDT
Created attachment 19391 [details]
Output from command: lspci -v
Comment 11 Need Real Name 2001-06-12 22:18:33 EDT
Running version 7.1 on a x686 platform we've also seen exactly the same 
symptoms although we aren't really accessing an smb drive but rather a 7.0 
RedHat system with NFS directories exported.  At some point after first 
accessing the NFS mounts the system freezes (no mouse/cursor operation 
possible) although telnet appears to connect but never gets to the login 
prompt.  Pings do work but any other form of network access fails (ftp, rsh, 
etc.).
Comment 12 Mauro Innocenti 2001-07-12 09:36:17 EDT
I have seen very similar freezes on my system running RH7.1 on i686 (PIII800)
even in console mode (just booted), all apparently when other hosts start SMB 
connections & transfers. The system freezes completely without any log and no 
other solution than resetting...
Comment 13 Arjan van de Ven 2001-07-12 09:40:09 EDT
Try the 2.4.3-12 updated kernel, WITHOUT the nvidia driver
Comment 14 Mauro Innocenti 2001-07-12 09:57:39 EDT
The freezes seem to be appeared exactly with the new 2.4 kernels.
I use the last 2.4.3-12 update recompiled just with modules I need
(no nvidia driver, but Matrox G450).
Comment 15 Mauro Innocenti 2001-07-12 09:58:43 EDT
Created attachment 23390 [details]
output of lscpi -v (from root)
Comment 16 Need Real Name 2001-07-12 10:13:06 EDT
I just have updated all available rpms from redhat including the kernel rpm and
problem disappears on both machines.
Thanks.
Comment 17 Mauro Innocenti 2001-07-12 11:23:14 EDT
I downgraded to the standard 2.4.2-2 (RH7.1 original) kernel and the problem
seems to be disappeared.
Comment 18 Mauro Innocenti 2001-07-16 11:27:57 EDT
All the problems seems to be resolved (almost for me) with the most recent "stable" kernel versions (2.4.5 / 2.4.6).

Note You need to log in before you can comment on or make changes to this bug.