Bug 412401 - mkdiskless should return a valid value on the exit
mkdiskless should return a valid value on the exit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.6
All Linux
low Severity low
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 11:54 EST by Ondrej Valousek
Modified: 2008-07-24 15:33 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0672
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:33:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.14 KB, patch)
2008-01-07 10:10 EST, Radek Brich
no flags Details | Diff

  None (edit)
Description Ondrej Valousek 2007-12-05 11:54:40 EST
Description of problem:
When I create a diskless image for the first time after rsyncing using the
mkdiskless script, it says:
ls: ./root/etc/rc.d/rc*.d/[KS]*diskless: No such file or directory
which looks like an error and indeed mkdiskless returns a non-zero value. But
apparently, image has been created correctly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. rsync the OS image 
2. run mkdiskless
3. check the return value
  
Actual results:
non-zero

Expected results:
If mkdiskless succeeded, it should return zero (and possibly suppress the
confusing "ls" output)

Additional info:
Comment 1 Radek Brich 2008-01-07 10:10:29 EST
Created attachment 290958 [details]
proposed patch

non-zero return value is caused by failing patch (the last), which should not
cause any problems (see #174629)
Comment 2 RHEL Product and Program Management 2008-01-07 10:15:55 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-07-24 15:33:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0672.html

Note You need to log in before you can comment on or make changes to this bug.