Bug 412481 - OOo, other apps fail with sigsegv
OOo, other apps fail with sigsegv
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.6
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://user.services.openoffice.org/e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 12:52 EST by Paul Williams
Modified: 2007-12-11 19:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 09:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of soffice 2.3 failing (same as soffice 2.2 and ati's catalyst control panel) (114.46 KB, text/plain)
2007-12-05 12:52 EST, Paul Williams
no flags Details
Xorg log (52.36 KB, text/plain)
2007-12-06 13:31 EST, Paul Williams
no flags Details
xorg configuration (2.92 KB, application/octet-stream)
2007-12-06 13:31 EST, Paul Williams
no flags Details

  None (edit)
Description Paul Williams 2007-12-05 12:52:37 EST
Description of problem:
After a recent update to my RHEL4 system, soffice fails to launch with a
sigsegv. The same error happens with versions 2.2 and 2.3 at about the same
place according to strace. Does anyone have a remedy for this issue?

Thanks!
~ Paul

Code: Select all
    ./soffice: line 251:  5275 Segmentation fault      "$sd_prog/$sd_binary" "$@"



In addition to the inline strace snippet below, I've attached the full strace
output.

Code: Select all
    [ DEV wyerd:/opt/openoffice.org2.0/opt/openoffice.org2.2/program ]
    0 > strace -f ./soffice
    execve("./soffice", ["./soffice"], [/* 36 vars */]) = 0
    uname({sys="Linux", node="wyerd.examen.com", ...}) = 0
    brk(0)                                  = 0x9d18000
    access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
    open("/usr/X11R6/lib/tls/i686/sse2/libtermcap.so.2", O_RDONLY) = -1 ENOENT
(No such file or directory)
    stat64("/usr/X11R6/lib/tls/i686/sse2", 0xbff70230) = -1 ENOENT (No such file
or directory)
    open("/usr/X11R6/lib/tls/i686/libtermcap.so.2", O_RDONLY) = -1 ENOENT (No
such file or directory)
    stat64("/usr/X11R6/lib/tls/i686", 0xbff70230) = -1 ENOENT (No such file or
directory)
    open("/usr/X11R6/lib/tls/sse2/libtermcap.so.2", O_RDONLY) = -1 ENOENT (No
such file or directory)
    (SNIP)
    [pid  5355] read(6, "i\0\0\0\6\0\0\0", 8) = 8
    [pid  5355] read(6, "j\0\0\0\6\0\0\0", 8) = 8
    [pid  5355] read(6, "k\0\0\0\1\0\0\0", 8) = 8
    [pid  5355] read(6, "l\0\0\0\1\0\0\0", 8) = 8
    [pid  5355] read(6, "m\0\0\0\1\0\0\0", 8) = 8
    [pid  5355] read(6, "n\0\0\0\1\0\0\0", 8) = 8
    [pid  5355] read(6, "o\0\0\0\10\0\0\0", 8) = 8
    [pid  5355] read(6, "p\0\0\0\10\0\0\0", 8) = 8
    [pid  5355] read(6, "q\0\0\0\10\0\0\0", 8) = 8
    [pid  5355] read(6, "r\0\0\0\10\0\0\0", 8) = 8
    [pid  5355] read(6, "\204\0\0\0\10\0\0\0", 8) = 8
    [pid  5355] --- SIGSEGV (Segmentation fault) @ 0 (0) ---
    Process 5344 resumed
    Process 5355 detached
    [pid  5356] <... futex resumed> )       = -1 EINTR (Interrupted system call)
    [pid  5356] +++ killed by SIGSEGV +++
    [pid  5344] <... waitpid resumed> [{WIFSIGNALED(s) && WTERMSIG(s) ==
SIGSEGV}], 0) = 5355
    [pid  5344] fstat64(2, {st_mode=S_IFREG|0664, st_size=304129, ...}) = 0
    (SNIP)
    [pid  5344] fstat64(3, {st_mode=S_IFREG|0644, st_size=1474, ...}) = 0
    [pid  5344] mmap2(NULL, 1474, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7da8000
    [pid  5344] close(3)                    = 0
    [pid  5344] write(2, "./soffice: line 251:  5355 Segme"..., 78./soffice:
line 251:  5355 Segmentation fault      "$sd_prog/$sd_binary" "$@"
    ) = 78
    [pid  5344] rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid  5344] --- SIGCHLD (Child exited) @ 0 (0) ---
    [pid  5344] waitpid(-1, 0xbff7016c, WNOHANG) = 0
    [pid  5344] sigreturn()                 = ? (mask now [])
    [pid  5344] rt_sigaction(SIGINT, {SIG_DFL}, {0x807612b, [], SA_RESTORER,
0x9b8908}, 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
    [pid  5344] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid  5344] exit_group(0)               = ?
    Process 5355 detached

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. attempt to run OOo or ATI Catalyst Control Center
2. Observe problem
  
Actual results:
./soffice: line 251:  5275 Segmentation fault      "$sd_prog/$sd_binary" "$@"


Expected results:
OOo windows.

Additional info:
URL attached has plenty of debugging information, straces and such.
Comment 1 Paul Williams 2007-12-05 12:52:37 EST
Created attachment 278641 [details]
strace of soffice 2.3 failing (same as soffice 2.2 and ati's catalyst control panel)
Comment 2 Matěj Cepl 2007-12-06 09:27:40 EST
There is a long list of issues I have with this bug:

a) If you have RH support, please, file an issue through IssueTracker. You will
get higher preference when going through there. If not, what kind of distro you
have? CentOS? Even if you don't have the real RHEL, it wouldn't be reason to
close this bug, but ...

b) /opt/openoffice.org2.0/ is not coming from the packages you got with RHEL4,
so we cannot resolve it here. If you want us to assist you with fixing this bug,
please, reproduce this with the OpenOffice.org packages you got with RHEL4.

c) ATI Catalyst Control Center is part of binary only ATI drivers. We are sorry
that we cannot help you with your problem, but we are not able to support
binary-only drivers.

Unfortuantely, b) and c) leads me to closing this bug as CANTFIX (because we
really cannot fix something we haven no source code for). If you would be able
to reproduce this issue using only open source software, please, reopen this bug
with the additional information.
Comment 3 Paul Williams 2007-12-06 11:37:20 EST
The reproducibility and straces lead me to believe there is an issue with the X
libraries used by both applications.  I understand that RH doesn't have access
to the catalyst drivers source, but RH certainly has access to the OOo sources.

This kind of attitude is what really drives me away from RH in general.  If this
were debian or ubuntu (or Slack back in the day), the community would be out
there helping.  But because it's RH, we're back to corporate only support.

Thanks for nothing.
Comment 4 Matěj Cepl 2007-12-06 11:55:28 EST
Please, note my comments under a) -- I explicitly emphasized that I am not
closing this bug because of not having support contract. We have thousands and
thousands Fedora (and CentOS) bugs here which are not closed and we are working
on them.

Concerning community -- just go ahead and ask community to help! Here is the
couple of tips where to go:

http://www.redhat.com/mailman/listinfo/fedora-list (probably the best option)
http://wiki.linuxquestions.org/wiki/Fedora (that's a little bit dated, though)
http://www.fedorafaq.org/
http://fedorasolved.org/
http://www.linuxquestions.org/questions/fedora-35/
http://fedoraproject.org/wiki/ (tones of information there)
Comment 5 Paul Williams 2007-12-06 12:08:42 EST
There is a support contract, managed by an overworked IT executive.  I don't
have access to the bloody contract support portal.
Comment 6 Paul Williams 2007-12-06 12:11:53 EST
I use linux on the desktop -- the only one in my local organization.  If I can't
get routine support easily it will never propogate beyond this (in fact, because
of this issue I may have to go back to windows.  I can't not edit my word docs).
Comment 7 Matěj Cepl 2007-12-06 12:52:38 EST
OK, so remove that OpenOffice.org which is not from us, and reinstall the
original packages from RHEL. Try if it works. If not, try again with open source
drivers (ati in your case). If *then* it doesn't work, you are very welcome to
reopen this bug (as I wrote in comment 2).

If you will reopen this bug, please, add to this bug as attachments content of
/etc/X11/xorg.conf and /var/log/Xorg.0.log as separate uncompressed attachments,
to allow us to debug your problem.
Comment 8 Paul Williams 2007-12-06 13:06:20 EST
As far as I can tell, there was no OOo distributed with RHEL which is why I
installed the OOo-provided version.  This is obviously a knowledge issue on my
part, and I have no access to the RH "channel management" or whatever you call
the automanagement tools.  

Clearly, being an active user of Linux since 1994 is not qualification enough
for administrating an Awesome RedHat system.

Please advise.
Comment 9 Paul Williams 2007-12-06 13:31:00 EST
Created attachment 280081 [details]
Xorg log
Comment 10 Paul Williams 2007-12-06 13:31:49 EST
Created attachment 280091 [details]
xorg configuration
Comment 11 Matěj Cepl 2007-12-06 18:04:17 EST
(In reply to comment #8)
> Please advise.

Packages named like openoffice.org2-writer are part of ES and AS channels of RHEL4.
Comment 12 Matěj Cepl 2007-12-07 03:23:52 EST
(In reply to comment #9)
> Created an attachment (id=280081) [edit]
> Xorg log

This is unfortunately still not good -- I am really sorry, but we really cannot
deal with flgrx. I accept all your complaints about quality of open source
drivers for ATI cards, and I can see that for somebody with real high end
requirements for graphics they might be unacceptably poor, but we really need
system clean of fglrx, before we can help you with crashes.

I am not saying, that fglrx is of poor quality (ATI engineers can certainly say
something similar about ati driver), but we have seen scores of bugs resolved
just by using open source drivers instead of fglrx (or nvidia for that matter).
Please, follow the instructions on
http://fedoraproject.org/wiki/Xorg/3rdPartyVideoDrivers for the way how to make
your computer clean of fglrx.
Comment 13 Paul Williams 2007-12-11 18:30:20 EST
This issue was resolved by moving the libGL.so.1.2 library that was replaced by
fglrx driver back to the system provided version.  <g>

Y'all are right -- binary drivers suck.

But the OSS radeon driver wedges the system -- not much of a choice.  For the
record, my options are limited by what the boss will buy, and today that's Dell.
 If I had the choice it'd be NV -- one of the older ones that works well with
the OSS NV driver.
Comment 14 Paul Williams 2007-12-11 18:50:14 EST
Oops.. it's back when I reenable DRI. :(  I guess DRI is the source of the
issue. How frustrating -- so slooooo without dri.
Comment 15 Paul Williams 2007-12-11 19:58:39 EST
Opened a ticket with ATI: 737-1297028

Note You need to log in before you can comment on or make changes to this bug.