Bug 412681 - RHN sends email regardless of preference
Summary: RHN sends email regardless of preference
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn500
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Sebastian Skracic
QA Contact: Bill C. Riemers
URL:
Whiteboard: US=16340
Keywords:
Depends On:
Blocks: 433460
TreeView+ depends on / blocked
 
Reported: 2007-12-05 19:45 UTC by Brad Hinson
Modified: 2008-04-07 20:00 UTC (History)
3 users (show)

Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 20:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad Hinson 2007-12-05 19:45:21 UTC
Description of problem:
RHN sends email notifications to organization admins on new user creation
regardless of 'receive email notification' check box in 'Your Preferences' page.
 If this box is unchecked, the admin should not receive these email.

Version-Release number of selected component (if applicable):
RHN 5.0.3

How reproducible:
100%

Steps to Reproduce:
Define an org admin, uncheck 'receive email notification' in preferences.  Add
user, org admin receives email.
  
Additional info:
Looks like this code was added (back) in bug 216756.

Comment 1 Brian Long 2008-01-08 16:39:46 UTC
This affects me directly and I'd like it to stop.  I should not receive an email
each time a new user is created in my group's Issue Tracker org.

Comment 2 Jie Chen 2008-01-18 20:13:12 UTC
I was able to reproduce the problem.  Here was what I did:
Logon using my account "jachengit" as org admin, uncheck 'receive email
notification' in preferences.  Add user jchen011808.  I receive a "Red Hat Login
Email Verificationan" email after I created the user.  
- Jie

Comment 3 Sebastian Skracic 2008-02-27 16:33:21 UTC
Fixed in r118561 - added code which checks for the 'receive email notification' when 
an email about new user creation is sent out to org admins.

Comment 4 Jie Chen 2008-02-28 16:54:20 UTC
I tested on webdev, it seems I still get email after creating new user with 
'receive email notification' unchecked.

Comment 5 Amy Owens 2008-03-04 15:40:25 UTC
see Jie's comments

Comment 6 Sebastian Skracic 2008-03-04 15:55:21 UTC
Are we maybe confusing the email sent to the created user herself (titled "Red Hat 
Login Email Verification") with that sent to the orgadmin (titled "RHN User 
Created: ...")?  The comment #2 from Jie might indicate that this is the case.  
Anyway, the fix (and hopefully the BZ entry itself) is about disabling the latter, 
ie. email titled "RHN USer Created ...".

Comment 9 Amy Owens 2008-03-05 18:18:58 UTC
Hey Sebastian,
This is all set (if your email ends in rhn.redhat.com you will get emails in dev
:) --I have an alias setup for other testing so I get emails for
aowens@rhn.redhat.com... 

Comment 10 Bill C. Riemers 2008-03-13 18:23:21 UTC
In order to verify this fix in QA, I will need e-mail to briemers@rhn.redhat.com
to work, and QA will need to be setup to send e-mails to rhn.redhat.com addresses.

Comment 11 Bill C. Riemers 2008-03-14 21:07:06 UTC
verified on webqa


Note You need to log in before you can comment on or make changes to this bug.