Bug 41270 - Application gets the SIGHUP after the write()
Application gets the SIGHUP after the write()
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 09:44 EDT by Shailendra Bist
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 13:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shailendra Bist 2001-05-18 09:44:13 EDT
Description of Problem:
I have two installations of Redhat Linux 7.0 (from the same CD). On one
installation of Redhat7.0 my application executes perfectly fine.

However, on other installation of Redhat7.0 the same application binary
always gets the SIGHUP after the write() call. The application is trying to
write() over the network. I ran the application through the debugger and
found no errno is set and the write() call returns successful, still after
the write() I get the SIGHUP.

How Reproducible:
I am not sure what is causing this (SIGHUP) problem to appear on only one
installation of Redhat7.0 and not on other.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Ulrich Drepper 2004-09-27 13:11:09 EDT
(The bug had the wrong component, which is why it has not been noticed.)

Why should anything like this have anything to do with glibc?  This is
either a kernel problem (very unlikely) or a program problem.  Run
strace if necessary to see what is happening.

I close this bug since it has nothing to do with glibc.

Note You need to log in before you can comment on or make changes to this bug.