Bug 41291 - crontab -e fails when /tmp is a softlink
crontab -e fails when /tmp is a softlink
Status: CLOSED DUPLICATE of bug 37994
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 11:04 EDT by ellson
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 17:35:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ellson 2001-05-18 11:04:10 EDT
Description of Problem:

We were tying to  make /tmp a softlink on a diskless sytem running RH7.1.

When /tmp is diirect, entring a comment such as "#hello"
into crontab works ok:

        $ crontab -e
                          << insert "#hello" in vim session here
        crontab: installing new crontab
        $

When /tmp is a softlink, entering a comment into crontab fails:

        $ mv /tmp /tmp.old
        $ ln -s /tmp.old /tmp
        $ crontab -e
                          << insert "#hello" in vim session here
        crontab: no changes made to crontab
        $

We think that the problem might be vim.  Changing vim to the version from
RH7.0 fixes the problem.

There are some comments in vixie-crontab code that refer to race
conditions, so perhaps a change in vim has just exposed one.
                


How Reproducible:
   100%
Comment 1 Eido Inoue 2002-02-12 14:26:30 EST

*** This bug has been marked as a duplicate of 37994 ***

Note You need to log in before you can comment on or make changes to this bug.