Bug 41330 - Whenever I shutdown (using shutdown -n now, halt, or reboot), system flushes ipcahins and says INIT: no more processes on this runlevel.
Whenever I shutdown (using shutdown -n now, halt, or reboot), system flushes ...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 18:02 EDT by Johnray Fuller
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-30 12:30:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2001-05-18 18:02:24 EDT
Description of Problem:

I am filing this bug on behalf of  acustomer who called. He will post to
this bug report ASAP.

What happened was he performed a Custom Installation (I think--Can you
verify this Steven?)--installing everything. The install appeare dto end
normally and he rebooted.

After that whenever he tried to shutdown or reboot, no matter how, he got
the following error after the ipchains were flushed:

INIT: no more processes on this runlevel

He would then turn off the system, which was partially halted.

>How Reproducible:

Every reboot this was happening

Steps to Reproduce:
1. Log in to GNOME/KDE 
2. Choose shutdown or reboot, or log in as root and enter halt. shutdown -h
now, reboot
3. INIT: no more processes on this runlevel

Actual Results:

had to manually power down system, causing an fsck on reboot....

Expected Results:

Wanted computer to power off...

Additional Information:
	
I investigated his rc.d directory and everything looked okay.

BUT, rc0.d and rc6.d DID NOT contain the sym-links to killall and halt. or
reboot respectively...

I had the customer create these sym-links and he was then able to
successfully shutdown with shutdown -r now... It DID NOT, however, reboot.
It powered off his system instead.

I had him reboot (he boots into runlevel 5) and checked the rc5.d. The
sym-link to rc.local was missing. I had him create this sym-link.

Again, he will post shortly...
Comment 1 Johnray Fuller 2001-05-18 18:04:47 EDT
p.s. I told him not to reinstall just yet until a developer gives the go
ahead...

It appears the installer did not properly finish its post install routines.

He has an new Athalon-based system...
Comment 2 Brent Fox 2001-05-20 10:39:15 EDT
This sounds like very strange behavior.  I would tell him to reinstall, doing
the exact same process and see if the same thing happens again.
Comment 3 Brent Fox 2001-05-30 12:30:52 EDT
Closing due to inactivity. Please reopen if you have more information.
Comment 4 vrossum 2001-07-29 11:02:51 EDT
Please reopen this bug.
I have the same problem on 7.1, it hangs at the same point.
P-III system with SCSI. 
Older versions of RH worked fine.

How can I trace where things go wrong ? /var/log/messages is useless here...

(Oh yes, I'm not going to reinstall, this is not supposed to be like MS)
Comment 5 vrossum 2001-08-03 10:44:37 EDT
I was able to fix it.
It was due to some incompatability between the 6.2 and 7.1 layout of the initscripts.
rc6.d should contain links to killall and reboot; it didnt

Note You need to log in before you can comment on or make changes to this bug.