Bug 413341 - Generated PostScript files have overlapping words.
Generated PostScript files have overlapping words.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 22:02 EST by Gian Paolo Mureddu
Modified: 2007-12-20 11:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:08:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How is the PostScript file displayed in Evince and flpsed (14.83 KB, image/png)
2007-12-05 22:02 EST, Gian Paolo Mureddu
no flags Details

  None (edit)
Description Gian Paolo Mureddu 2007-12-05 22:02:45 EST
Description of problem:
When printing to a file, for instance from Firefox, the generated .ps file
contains overlapping words in some paragraphs. Some times cleaning the original
HTML code may help, some times no matter what I do, the generated files contain
these problems (see attached screenshot)

Version-Release number of selected component (if applicable):
ghostscript-8.60-5.fc8.x86_64
ghostscript-fonts-5.50-18.fc8
ghostscript-8.60-5.fc8.i386

How reproducible:
Frequently, some files may be easier than others.

Steps to Reproduce:
Since the problem doesn't show in many situations, there is no ordered way to
reproduce it, however, recurrently I've seen that trying to "print to file" from
Firefox (Epiphany and Galeon also show this) this file
(http://agile.csc.ncsu.edu/iTrust/doc/formalreqs.html) yields exactly the same,
or similar as the attached image.
  
Actual results:
Word overlapping is seen when "printing to file" from some sites in Mozilla
compatible browsers which use ghostscript, on certain files.

Expected results:
Words to not overlap (like is the case with Konqueror's PDF "printer")

Additional info:
In general (and I'm not sure if this makes this fall outside the scope of
ghostscript), I've seen this happen with sites whose pages are generated by
either Microsoft Word or in some cases Exchange.
Comment 1 Gian Paolo Mureddu 2007-12-05 22:02:45 EST
Created attachment 279101 [details]
How is the PostScript file displayed in Evince and flpsed
Comment 2 Tim Waugh 2007-12-10 08:15:16 EST
This is a Firefox problem.
Comment 3 Gian Paolo Mureddu 2007-12-13 04:36:06 EST
Ok, so it is a problem on how Firefox formats the PS file? It is a problem local
to how Firefox uses GS for this? I much better like the results of FF for many
things (proper text color, for instance, and much better table management, than
Konqueror's PDF printer). Is this a known bug upstream?
Comment 4 Christopher Aillon 2007-12-20 11:08:01 EST
This looks much better in firefox 3, which is now in rawhide and will be shipped
as part of Fedora 9.  Because of the many changes that updating will require to
various packages, we will not be fixing this in F8, though.   Sorry.  :-(

Note You need to log in before you can comment on or make changes to this bug.