Bug 41352 - HP DeskJet 890C failure
HP DeskJet 890C failure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-19 07:56 EDT by Dimitri Papadopoulos
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 17:52:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitri Papadopoulos 2001-05-19 07:56:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
When booting init script /etc/rc.d/init.d/lpd writes the following
message to the screen:
	Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
	Winbond chip at EFER=0x3f0 key=0x87 devid=52 devrev=f1 oldid=ff
	Winbond chip type 83977EF / SMSC 97w35x
	Winbond LPT Config: cr_30=01 60,61=0378 70=07 74=03, f0=00
	Winbond LPT Config: active=yes, io=0x0378 irq=7, dma=3
	Winbond LPT Config: irqtype=pulsed low, high-Z, ECP fifo threshold=0
	Winbond LPT Config: Port mode=Standard (SPP) and Bidirectional(PS/2)
	SMSC Super-IO detection, now testing Ports 2F0, 370 ...
This message is written while executing /usr/sbin/checkpc as far as
I can tell.

Also I cannot reproduce this after booting, for example by running
	/etc/rc.d/init.d/lpd stop
then
	/etc/rc.d/init.d/lpd start
The message shows only when rebooting the machine.

I'm not sure what this means. This message can be misinterpreted as an
error message and is confusing.

For what it's worth, my motherboard is a twin-Celeron ABIT BP-6 and
I have an HP DeskJet 890C printer attached to the parallel port. The
printer is powered off.


How reproducible:
Always

Steps to Reproduce:
1. Boot machine with RedHat Linux 7.1
2. Look at bootup messages 


Actual Results:  I see this asynchronous annoying message in the middle of
the
"Starting ... [OK]" bootup messages:
	Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
	Winbond chip at EFER=0x3f0 key=0x87 devid=52 devrev=f1 oldid=ff
	Winbond chip type 83977EF / SMSC 97w35x
	Winbond LPT Config: cr_30=01 60,61=0378 70=07 74=03, f0=00
	Winbond LPT Config: active=yes, io=0x0378 irq=7, dma=3
	Winbond LPT Config: irqtype=pulsed low, high-Z, ECP fifo threshold=0
	Winbond LPT Config: Port mode=Standard (SPP) and Bidirectional(PS/2)
	SMSC Super-IO detection, now testing Ports 2F0, 370 ...


Expected Results:  This message should not appear on the screen. It is
confusing.


Additional info:
Comment 1 Dimitri Papadopoulos 2001-05-19 12:16:24 EDT
May I add that I cannot print with Red Hat Linux 7.1, although this used to
work with Red Hat Linux 6.2. I've used printtool/printconf-gui to configure
my HP DeskJet 890C but all it prints is:
	Unknown device: cdj890
Maybe this is related...
Comment 2 Crutcher Dunnavant 2001-05-21 14:12:24 EDT
The messages are from modprobe inserting the module, you wouldnt see them at a
different log level. changing to a deskjet bug
Comment 3 Dimitri Papadopoulos 2001-08-19 13:28:05 EDT
This is indeed a deskjet bug. I've used printconf-gui to revert to cdj550 (the
same driver
I was using successfully under Red Hat 6.2). Everything works just fine, I am
now able to
print. Thanks for the info! Changing back to the cdj890 driver causes the same
printing
problems again.

As for the messages from modprobe inserting the module, I'm using the default
log level.
I believe I shouldn't see them at the default log level, should I?
Comment 4 Tim Waugh 2001-12-19 07:44:46 EST
The current errata kernel should send those messages at a lower priority, so 
that they don't appear on the console.  Closing this bug report.

Note You need to log in before you can comment on or make changes to this bug.