This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 413861 - Perl update broke Scalar:Util
Perl update broke Scalar:Util
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 08:10 EST by Boris Goldowsky
Modified: 2008-03-06 09:03 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-5.8.8-36
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 09:03:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Goldowsky 2007-12-06 08:10:33 EST
Version-Release number of selected component (if applicable):
perl-5.8.8-32.fc8.x86_64

How reproducible:
always

Since the update to version mentioned above, some Fedora-packaged perl programs
that depend on the Scalar:Util will throw errors or warnings.  For instance GET:

$ GET -d http://fedora.us/
Use of uninitialized value in concatenation (.) or string at
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/Scalar/Util.pm line 30.

Also BackupPC is encountering a similar error.

It can be localized to the Scalar:Util import wanting a particular feature:

$ perl -e 'use Scalar::Util qw(dualvar);'
 is only avaliable with the XS version at -e line 1

And I found an email thread related to this:

http://www.nntp.perl.org/group/perl.cpan.testers/2007/07/msg538118.html
Comment 1 Boris Goldowsky 2008-02-22 12:38:10 EST
I applied a workaround, and then this happened again with the recent update to
perl-5.8.8-33.fc8.x86_64.

Increasing to high severity since it breaks multiple standard Fedora-installed
programs that depend on perl.



Comment 2 GeoffLeach 2008-02-23 17:14:11 EST
Not supprisingly perhaps, its also broken in perl-5.8.8-33.fc8. FWIW, a
workaround is to force install of List::Util in cpan.
Comment 3 Marcela Mašláňová 2008-03-06 09:03:04 EST
The package perl-5.8.8-36 upgrade the Scalar::Util on the latest version. The
problem with XS support, weaken and other functions provided by Scalar::Util
should be fixed by this update. 
If you problem persist, please feel free to reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.