Bug 41394 - sndconfig dumps core
Summary: sndconfig dumps core
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 47079 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-19 23:49 UTC by Andrey Kartashov
Modified: 2014-03-17 02:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-19 23:49:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrey Kartashov 2001-05-19 23:49:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3 i686; en-US; 0.8.1) Gecko/20010326

Description of problem:
sndconfig dumps core after playing sound sample if environment variable
LANG is absent

How reproducible:
Always

Steps to Reproduce:
1. unset LANG
2. interact with sndconf
3. it'll crash after playing sound sample
	

Actual Results:  sndconfig dumps core

Expected Results:  :) should work :)

Additional info:

(gdb) bt
#0  0x400b1fd3 in strncmp (s1=0x0, s2=0x8071571 "sv", n=2)
    at ../sysdeps/generic/strncmp.c:64
#1  0x0804dd8d in TestSndCard (tmpfile=0xbffff810 "/etc/sndconfig-ZAnTOd",
    dopnp=1, set=0xbffff350) at sndconfig.c:1416
#2  0x0804fd9c in main (argc=1, argv=0xbffff8bc) at sndconfig.c:2017
#3  0x40048177 in __libc_start_main (main=0x804e970 <main>, argc=1,
    ubp_av=0xbffff8bc, init=0x80499bc <_init>, fini=0x806fd40 <_fini>,
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffff8ac)
    at ../sysdeps/generic/libc-start.c:129

Quick fix:
[root@linux sndconfig-0.64.8]# diff sndconfig.c sndconfig.c_orig
1416c1416
<       if (sample && (!strncmp(sample,"sv",2)))
---
>       if (!strncmp(sample,"sv",2))

Comment 1 Bill Nottingham 2001-05-21 18:18:39 UTC
Oops, will be fixed in 0.65.9-1. Thanks!

Comment 2 Bill Nottingham 2001-07-06 04:09:30 UTC
*** Bug 47079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.