Bug 41395 - bad kde crash system (hang)
bad kde crash system (hang)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-19 20:41 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 05:15:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-19 20:41:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
while logging in; during KDE startup, I fast clicked on the flashing icons;
crash - had to reboot to get the system back

How reproducible:
Always

Steps to Reproduce:
1.login using 
2.click real fast
3.die!
	

Actual Results:  system hangs NOTHING seems to do anything!

Expected Results:  login completion

Additional info:

feel free to send question by email if you have them. 
Oh BTW I am using a cheapbytes version of 7.1 which, presumably
is download version
dkr
Comment 1 Bernhard Rosenkraenzer 2001-05-20 06:02:33 EDT
I can't reproduce this.
Do you get anything about this in /var/log/messages?
Is your machine connected to a network? If so, can you still ping its IP when 
this happens?
Which graphics card are you using?

Comment 2 Adam Tibbalds 2001-05-21 06:41:10 EDT
Having a similar issue.
Dell Precision 220 (two PIII 866MHz) Intel 820 chipset.
Matrox Millenium G400 MAX
No SCSI (I took it out!).
One /boot partition (133MB), one swap (133MB) and one / (~9GB) 

Redhat 7.1 downloaded+updates as of 18 May '01

Install detects SMP OK (no need to select from package list) but leaves APMD running (I thought this was a bad thing?)

No problems when booting into linux-up kernel.
No problems (yet?) when using GNOME.

Steps to reproduce:
1 - boot into linux (as opposed to linux-up)
2 - Login to KDE (if using run level 5) or 'startx' (if using runlevel 3)
3 - machine completely hangs during the 'Initializing peripherals' phase (i.e. icon may flash a couple of times before the hang)

Cannot 'ping' from another machine.  Any text consoles used prior to 'startx' cannot be accessed.
Only recourse is to hard reset.  Then machine will not boot as there are so many file system errors (so I will have difficulty supplying any log files) and 
the only option seems to be to reinstall from scratch.  Have observed damage to /boot as well on one occasion.

Feel free to email if appropriate.
Comment 3 Bernhard Rosenkraenzer 2001-05-21 06:48:29 EDT
apmd won't do anything in SMP mode because the kernel won't handle the APM 
events, so that's not the problem.

I can't reproduce this even on a similar machine (2xPIII 450, G200)...

Arjan, are there any known bugs with the SMP kernel that could cause this?
Mike, are there any known problems in XFree86 that might be related?
Comment 4 Arjan van de Ven 2001-05-21 06:56:57 EDT
KDE had some issues on SMP with the i810 sounddriver but I thought we resolved
that before the release. Do both of you have i810 audio drivers ?
Comment 5 Adam Tibbalds 2001-05-21 07:10:34 EDT
I have a Sound blaster compatible which is on the motherboard:
Analog Devices AD1881 AC97 Codec

To be honest I have not tested the sound yet.

Is there any system info that I could get before trying the smp kernel that would be useful to you?

Alternatively, as I am not very experienced with dealing with damaged filesystems, is there any source of information that you could point me to so that I 
could at least get some log files from after the event?   Currently it dumps me out into the enter-root-password-to-manually-run-fsck mode where I am a 
bit lost!

Comment 6 Need Real Name 2001-05-21 20:43:52 EDT
OK folks - I have put a LOT of time in on this over the long (Canadian) 
weekend. By Sunday after noon the Matrox Millennium II video card
was leaving streaks across the screen pretty much all of the time. Soooo
I went & bought a GeForce2MX based card. 

After plenty of trouble getting this card to work I have succeeded in 
eliminating the problem. 

After damaging my file system I saved my user space & reloaded the entire 
system. The card came up without trouble during the install.

The clicking problem is not there anymore.

All is now well in my computer.

Thank you all for the help!

dkr
Comment 7 Mike A. Harris 2001-05-21 21:11:02 EDT
No, I haven't heard of anything like this for the Mill II card.  It could
possibly be buggy hardware, but it is hard to say without knowing more.
I've got a Mill II here I think.  I'll give it a test sometime soon, and
get back...
Comment 8 Adam Tibbalds 2001-05-22 07:10:56 EDT
Further news:

My setup seems to work OK if I select a 1280x1024x16bpp graphics mode (using the Matrox G400 driver)
It also seems happy with the generic SVGA manually selected during setup.

But as soon as I use XConfigurator to select a 1280x1024x24bpp (which is what I normally use on this machine) and run startx, it hangs, needs hard 
reset and wastes the file system (as before).

So I guess it is an interaction between KDE and the XFree Matrox G400 driver.

Does this help?
Comment 9 Mike A. Harris 2001-05-22 07:19:36 EDT
I cannot reproduce on my Millenium 2.  My guess is that you are trying to
use too high a resolution/depth, and possibly have DRI enabled.
Make sure DRI is not enabled, and lower your res and/or bit depth and
see fi the problem goes away.  Does it?
Comment 10 Adam Tibbalds 2001-05-29 13:37:35 EDT
I do not have DRI running at all (at least there are no mentions of it in the startx output text)
I have tried different resolutions and the 1280x1024x24bpp always hangs/crashes and I have also observed kernel panics (with associtated filesystem 
corruption) in 1024x768x24bpp as well.
With the uniprocessor kernel, everything seems fine.

I can only assume that it is some obscure interaction between smp, kde and the xfree matrox driver.
Comment 11 Mike A. Harris 2001-06-04 03:26:52 EDT
If the kernel is panicing it is definitely not a KDE bug, nor an X bug.
It is either a kernel bug, hardware problem, flaky memory or somesuch.
Do you overclock?
Comment 12 Adam Tibbalds 2001-06-07 05:15:54 EDT
Hi, I don't overclock - it's an un-fiddled-with Dell Precision Workstation 220.

I have also experimented with Mandrake 8.0, which I thought had solved the problem as I had successfully run several times in KDE at the 
1280x1024x32bpp resolution with no problems.  Then it did exactly the same thing (i.e. totally hung during KDE startup on the peripherals icon and 
trashed the filesystem).  I do realise that Mandrake and RedHat are based on the same packages but I was just testing whether there were enough 
differences in compile options or exact package versions - apparently there are not!

Unfortunately I nearly lost my NT setup this time as well (don't ask me why - NT suddenly decided that my second NTFS partition was a type 17 Hidden 
NTFS even though my Linux installation was on a completely different drive).  As this is my work PC (and hence relient on NT) I'm afraid I cannot take the 
risk of further damage (or time spent).  I will have to give up on this until I can get my hands on a machine that I can use soley for running/experimenting 
with Linux.

Sorry!
Comment 13 Bernhard Rosenkraenzer 2001-08-10 05:41:30 EDT
Closing (no way to reproduce)

Note You need to log in before you can comment on or make changes to this bug.