Bug 414241 - d4x fails to rebuild
d4x fails to rebuild
Status: CLOSED DUPLICATE of bug 427620
Product: Fedora
Classification: Fedora
Component: d4x (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 11:12 EST by Jesse Keating
Modified: 2013-01-09 21:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 08:45:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-12-06 11:12:34 EST
if g++ -DHAVE_CONFIG_H -I. -I. -I../..   -I/usr/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0
-I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/kerberos/include -include ../../config.h  -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT about.o -MD -MP -MF
".deps/about.Tpo" -c -o about.o about.cc; \
	then mv -f ".deps/about.Tpo" ".deps/about.Po"; else rm -f ".deps/about.Tpo";
exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I../..   -I/usr/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0
-I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/kerberos/include -include ../../config.h  -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT fsched.o -MD -MP -MF
".deps/fsched.Tpo" -c -o fsched.o fsched.cc; \
	then mv -f ".deps/fsched.Tpo" ".deps/fsched.Po"; else rm -f ".deps/fsched.Tpo";
exit 1; fi
fsched.cc: In function 'GtkWidget* d4x_scheduler_init()':
fsched.cc:251: error: 'gtk_widget_ref' was not declared in this scope
fsched.cc: In function 'void my_gtk_aeditor_browse_ok(GtkWidget*, MyGtkAEditor*)':
fsched.cc:295: error: 'GTK_FILE_SELECTION' was not declared in this scope
fsched.cc:295: error: 'gtk_file_selection_get_filename' was not declared in this
scope
fsched.cc: In function 'void my_gtk_aeditor_browse(GtkWidget*, MyGtkAEditor*)':
fsched.cc:309: error: 'gtk_file_selection_new' was not declared in this scope
fsched.cc:312: error: 'GTK_FILE_SELECTION' was not declared in this scope
fsched.cc:312: error: 'gtk_file_selection_set_filename' was not declared in this
scope
fsched.cc:314: error: 'GTK_FILE_SELECTION' was not declared in this scope
fsched.cc: At global scope:
fsched.cc:113: warning: 'gint compare_nodes2(const void*, const void*)' defined
but not used
make[3]: *** [fsched.o] Error 1
make[3]: *** Waiting for unfinished jobs....
about.cc: In function 'void init_about_window(...)':
about.cc:176: warning: comparison between signed and unsigned integer expressions
about.cc:185: warning: comparison between signed and unsigned integer expressions
make[3]: Leaving directory `/builddir/build/BUILD/d4x-2.5.7.1/main/face'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/d4x-2.5.7.1/main'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/d4x-2.5.7.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.71182 (%build)
Comment 1 Matthias Saou 2008-01-17 08:45:17 EST
Resolving as duplicate of #427620 (which is "newer", so it should be the other
way around, but since that one contains all the details, it makes most sense).

*** This bug has been marked as a duplicate of 427620 ***

Note You need to log in before you can comment on or make changes to this bug.