Bug 41434 - New RH 7.1: First Boot: Deskguide applet dies.
Summary: New RH 7.1: First Boot: Deskguide applet dies.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-20 13:05 UTC by Bryce Nesbitt
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 16:25:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryce Nesbitt 2001-05-20 13:05:52 UTC
Description of Problem:

On a working RH 7.0 system, I installed 7.1 on a new partition.  On
starting Gnome as a user or root I get:
   "Deskguide (the desktop pager) applet appears to have died unexpectedly. 
   Reload this applet?"
Reloading results in the same message.  Cancel only works for a while, then
it comes back.


Additional Information:
	It's a totally stock RH 7.1 system, but runs Accellerated X from
http://www.xig.com
	(build 6000/DENALI,AX).  I can't run XFree on this video card, otherwise
I'd
	try it.

Comment 1 Havoc Pennington 2001-05-21 14:38:41 UTC
It probably is an AccelX interaction. Do you have anything in ~/.xsession-errors
(or if you used startx, on the console you started X from)? DeskGuide probably
printed some sort of error message.

Comment 2 Bryce Nesbitt 2001-05-21 16:37:54 UTC
Here's the output.  I started with a recent Xaccel, and just to be sure upgraded
to the latest patch.  It's still here:

---------------------------------------------------------
Xaccel 6.0 (build 6000/DENALI,AX) Accelerated-X (tm) Display Server
Copyright (c) 1993-2000 by Xi Graphics, Inc.
All Rights Reserved
Unpublished -- Rights reserved under the Copyright Laws of the United States

User:          Bryce Nesbitt
Organisation:  Obviously Enterprises
Serial Number: AXJTRS-0309438626-96

Configuration file: /etc/Xaccel.ini
LINUX(i386) using /dev/tty7

PCI (#1/2, 8000000c)
Permedia3,1: RX (32768k @dc000000)
Input 0: Generic US American Keyboard, v0
Input 1: Generic PS/2 (3 Button) Mouse, v0
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/2607
Xlib:  extension "XINERAMA" missing on display ":0.0".
subshell.c: couldn't get terminal settings: Inappropriate ioctl for device

GnomeUI-WARNING **: Could not open help topics file NULL
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 1000 error_code 8 request_code 128 minor_code 3
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
xinit:  connection to X server lost.^M
^M
waiting for X server to shut down ICE default IO error handler doing an exit(),
pid = 2618, errno = 0
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).

Gdk-WARNING **: GdkWindow 0x2c0004a unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x2c00046 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x2c00042 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x2c0003e unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x2c0003d unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x2c00016 unexpectedly destroyed
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).

Gdk-WARNING **: GdkWindow 0x300002a unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x3000028 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x3000027 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x3000015 unexpectedly destroyed
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
ICE default IO error handler doing an exit(), pid = 2622, errno = 0     


Comment 3 Havoc Pennington 2001-05-21 17:54:49 UTC
Hard to tell which messages might be from desk guide - maybe you could "tail -f
.xsession-errors" as you try adding the applet, and see what appears right as
the applet dies?

Though I'm guessing it's that BadMatch, which will be hard to debug since I
don't have AccelX to reproduce it.

Comment 4 Bryce Nesbitt 2001-05-21 22:24:50 UTC
You can download a free 10 minute-limited version from http://www.xig.com
 Bryan Chambers <chambers@xig.com> is the contact.  But I think it is clear this
is an AccelX problem, not a generic Gnome/RedHat packaging issue.

Comment 5 Bryce Nesbitt 2001-05-22 16:25:10 UTC
The bug is more noticable if you set "16M with overlays" as the color mode.

Comment 6 Havoc Pennington 2001-07-09 02:05:52 UTC
Forwarded this upstream as http://bugzilla.gnome.org/show_bug.cgi?id=57261


Note You need to log in before you can comment on or make changes to this bug.