Bug 414401 - NetworkManager fails to initiate vpnc. Complains of 'configuration error'.
NetworkManager fails to initiate vpnc. Complains of 'configuration error'.
Status: CLOSED DUPLICATE of bug 409351
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
i386 Linux
high Severity urgent
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 12:17 EST by Christopher J. Buckley
Modified: 2007-12-06 17:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 17:20:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher J. Buckley 2007-12-06 12:17:50 EST
Description of problem:

Today I was notified of updates for F8. One was NetworkManager. After update, I
am completely unable to connect to an IPSec VPN via NetworkManager. vpnc command
line works fine still.  

The applet crashes and generates a bug report.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.6.6.svn3109.fc8

How reproducible:

100%

Steps to Reproduce:
1.  Create a vpn-ipsec configuration
2.  At the last stage, it crashes - everytime, reproducable.

1.  Import a saved vpn configuration. 
2.  attempting to connect generates the included output.
  
Actual results:

Dec  6 16:15:07 localhost NetworkManager: nm-vpn-connection.c.661: NeedSecrets
failed: g-exec-error-quark Could not process the request because the VPN
connection settings were invalid.
Dec  6 16:15:35 localhost NetworkManager: nm-vpn-connection.c.661: NeedSecrets
failed: g-exec-error-quark Could not process the request because the VPN
connection settings were invalid.

This configuration worked fine before NM update.

[main]
Description=vpn
Host=
AuthType=1
GroupName=foo bar
GroupPwd=
EnableISPConnect=0
ISPConnectType=0
ISPConnect=
ISPCommand=
Username=
SaveUserPassword=0
EnableBackup=0
BackupServer=
EnableNat=1
CertStore=0
CertName=
CertPath=
CertSubjectName=
CertSerialHash=
DHGroup=2
ForceKeepAlives=0
enc_GroupPwd=
UserPassword=
enc_UserPassword=
NTDomain=
EnableMSLogon=0
MSLogonType=0
TunnelingMode=0
TcpTunnelingPort=10000
PeerTimeout=90
EnableLocalLAN=1
SendCertChain=0
VerifyCertDN=
EnableSplitDNS=1
SPPhonebook=
X-NM-Routes=172.16.0.0/16 10.0.0.0/8 192.168.0.0/16
Comment 1 Denis Leroy 2007-12-06 17:20:57 EST

*** This bug has been marked as a duplicate of 409351 ***

Note You need to log in before you can comment on or make changes to this bug.