Bug 414441 - gdal fails to rebuild due to compile error (once grass support is disabled)
gdal fails to rebuild due to compile error (once grass support is disabled)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On: 189337
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 12:34 EST by Jesse Keating
Modified: 2013-01-09 21:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-12 20:20:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)
Patch against devel/gdal.spec (2.45 KB, patch)
2008-01-03 17:58 EST, Alex Lancaster
no flags Details | Diff

  None (edit)
Description Jesse Keating 2007-12-06 12:34:51 EST
gdal needs to rebuild for openssl soname bump.  I tried disabling the
grass-devel build requires, but that doesn't seem to have worked.  Not only that
gdal tried to bring gdal-devel in (perhaps for grass-devel?)

Can you please work on this to get a build of gdal (without grass) built, so
that we can build grass against it?

http://koji.fedoraproject.org/koji/taskinfo?taskID=279623
Comment 1 Jesse Keating 2007-12-09 09:42:19 EST
Update.  I forcefully disabled grass in the spec and now the build gets to
start, but fails due to a compile error:

 g++ -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -I/builddir/build/BUILD/gdal-1.4.2-fedora/port
-I/builddir/build/BUILD/gdal-1.4.2-fedora/gcore
-I/builddir/build/BUILD/gdal-1.4.2-fedora/alg
-I/builddir/build/BUILD/gdal-1.4.2-fedora/ogr
-I/builddir/build/BUILD/gdal-1.4.2-fedora/ogr/ogrsf_frmts -I/usr/include/hdf
-I/builddir/build/BUILD/gdal-1.4.2-fedora/ogr -Ihdf-eos -DOGR_ENABLED
-I/usr/include/ogdi -I/usr/include/netcdf-3 -I/usr/include/hdf
-I/usr/include/libgeotiff -I/usr/include/libdap
-I/builddir/build/BUILD/gdal-1.4.2-fedora/port -Iexternal/include
-I/usr/include/cfitsio -I/usr/include/cfitsio/include -c hdf4dataset.cpp  -fPIC
-DPIC -o ../o/.libs/hdf4dataset.o
hdf4dataset.cpp: In member function 'CPLErr
HDF4Dataset::ReadGlobalAttributes(int32)':
hdf4dataset.cpp:576: error: 'MAX_NC_NAME' was not declared in this scope
hdf4dataset.cpp:589: error: 'szAttrName' was not declared in this scope
hdf4dataset.cpp: In static member function 'static GDALDataset*
HDF4Dataset::Open(GDALOpenInfo*)':
hdf4dataset.cpp:746: error: 'MAX_VAR_DIMS' was not declared in this scope
hdf4dataset.cpp:831: error: 'aiDimSizes' was not declared in this scope
hdf4dataset.cpp:931: error: 'aiDimSizes' was not declared in this scope
hdf4dataset.cpp:982: error: 'aiDimSizes' was not declared in this scope
hdf4dataset.cpp:1004: error: 'aiDimSizes' was not declared in this scope
hdf4dataset.cpp:1033: error: 'aiDimSizes' was not declared in this scope
hdf4dataset.cpp:1040: error: 'aiDimSizes' was not declared in this scope
make[2]: *** [../o/hdf4dataset.o] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/gdal-1.4.2-fedora/frmts/hdf4'
make[1]: *** [hdf4-install-obj] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/gdal-1.4.2-fedora/frmts'
make: *** [frmts-target] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.16196 (%build)

http://koji.fedoraproject.org/koji/getfile?taskID=284310&name=build.log
Comment 2 Alex Lancaster 2007-12-19 06:30:54 EST
Ping?  Can the maintainer please respond?  This has been broken in rawhide for
almost 2 weeks and it blocking the rebuild of several other packages including
grass, mapserver and others.
Comment 3 Alex Lancaster 2007-12-19 07:13:53 EST
Hmm, a clue seems to be that since gdal was last rebuilt, the hdf package which
is a BuildRequires, has undergone a version upgrade:

http://koji.fedoraproject.org/koji/buildinfo?buildID=22692

and from the changelog it looks like it has done some odd business with the netcdf:

* Mon Oct 29 2007 Patrice Dumas <pertusus@free.fr> 4.2r2-4
- install the netcdf.h file that describes the netcdf2 hdf enabled
  API

* Mon Oct 29 2007 Patrice Dumas <pertusus@free.fr> 4.2r2-3
- ship hdf enabled nc* utils as hnc*
- add --disable-netcdf that replaces HAVE_NETCDF
- keep include files timestamps, and have the same accross arches
- fix multiarch difference in include files (#341491)

* Wed Oct 17 2007 Patrice Dumas <pertusus@free.fr> 4.2r2-2
- update to 4.2r2

and I notice on the gdal wiki it mentions some compatibility issues with netcdf:

http://trac.osgeo.org/gdal/wiki/HDF
Comment 4 Alex Lancaster 2007-12-30 20:37:26 EST
Investigating this it appears that some changes in hdf causes this (see bug #189337)

Bumping priority and severity as this continues to block 4 or 5 other packages
and causes many broken deps in rawhide.
Comment 5 Mamoru TASAKA 2008-01-01 12:12:06 EST
As the reviewer of gdal, I tried to check and with some fixes
gdal builds.
http://koji.fedoraproject.org/koji/taskinfo?taskID=317495

However, it seems that Balint does not allow cvsgroup access...
Comment 6 Alex Lancaster 2008-01-03 17:58:17 EST
Created attachment 290803 [details]
Patch against devel/gdal.spec 

This is the patch against the spec file extracted from the SRPM mentioned in
comment #5 above.  Please apply ASAP.
Comment 7 Balint Cristian 2008-01-04 15:46:59 EST
(In reply to comment #5)
> As the reviewer of gdal, I tried to check and with some fixes
> gdal builds.
> http://koji.fedoraproject.org/koji/taskinfo?taskID=317495
> 
> However, it seems that Balint does not allow cvsgroup access...

Hello Tasaka, Jesse

Would you like please to grant for my Balint Cristian <rezso@rdsor.ro> aceess:

My account looks like this (i pass CLA and so on):
cvsextras 	rezso 		user 	unapproved 	None
fedorabugs 	rezso 		user 	unapproved 	Unneeded

I guess i need new sponsorshisp since i cannot access cbalint@redhat.com
anymore, so i have to use non RH account for future.



Comment 8 Balint Cristian 2008-01-04 17:08:15 EST
Package Change Request
======================
Package Name: gdal
Owners: rezso@rdsor.ro
Comment 9 Dennis Gilmore 2008-01-05 13:38:01 EST
Owner needs to be a fas account name  not an email address.
Comment 10 Balint Cristian 2008-01-05 14:22:11 EST
Package Change Request
======================
Package Name: gdal
Owners: rezso
Comment 11 Kevin Fenzi 2008-01-05 16:51:37 EST
cvs done.
Comment 12 Alex Lancaster 2008-01-12 20:20:56 EST
This is now fixed, so closing bug.   But the new rebuild introduced some bogus
Perl deps which cause more broken deps (I've opened up a separate bug: bug #428541)

Note You need to log in before you can comment on or make changes to this bug.