Bug 414471 - after recent updates rpc stopped working completely with ipv4
after recent updates rpc stopped working completely with ipv4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 13:15 EST by Jussi Eloranta
Modified: 2008-01-11 17:15 EST (History)
0 users

See Also:
Fixed In Version: 0.1.7-14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:15:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failed rpcinfo -o <server> with ipv6 in netconfig (16.86 KB, application/octet-stream)
2007-12-06 13:15 EST, Jussi Eloranta
no flags Details
ipv6 removed - everything works again (29.48 KB, application/octet-stream)
2007-12-06 13:16 EST, Jussi Eloranta
no flags Details

  None (edit)
Description Jussi Eloranta 2007-12-06 13:15:26 EST
Description of problem:

$ rpcinfo -p chemserv
rpcinfo: can't contact portmapper: RPC: Unknown host

RPC services don't work at all anymore. If I remove ipv4 from /etc/netconfig,
everything starts working again.

I have attached strace from rpcinfo -p <servername> which always
returns unknown host if ipv6 appears in /etc/netconfig.

Version-Release number of selected component (if applicable):

Fedora 8 RPC

How reproducible:

Update to latest Fedora 8 (and 7 seems to be affected as well)
Comment 1 Jussi Eloranta 2007-12-06 13:15:26 EST
Created attachment 280061 [details]
Failed rpcinfo -o <server> with ipv6 in netconfig
Comment 2 Jussi Eloranta 2007-12-06 13:16:44 EST
Created attachment 280071 [details]
ipv6 removed - everything works again
Comment 3 Jussi Eloranta 2007-12-07 14:19:31 EST
OK - this was not as bad as I thought first. The services seem to work.
Just rpcinfo doesn't.
Comment 4 Fedora Update System 2007-12-20 14:55:02 EST
libtirpc-0.1.7-14.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libtirpc'
Comment 5 Fedora Update System 2008-01-11 17:15:40 EST
libtirpc-0.1.7-14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.