Bug 414711 - Re-enable egg building for distutils
Re-enable egg building for distutils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 14:38 EST by Toshio Ernie Kuratomi
Modified: 2007-12-20 22:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 22:35:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2007-12-06 14:38:57 EST
Description of problem:
Upstream python-2.5 builds eggs for distutils using packages.  This is disabled
via a short patch in our build; probably due to thinking eggs are only a package
format and duplicate the duties of rpm.

Unfortunately, eggs are not just an installable format but also contain
information that is needed at runtime.  Please see the "Why Eggs" section of:
  http://fedoraproject.org/wiki/Packaging/Python/Eggs

I talked with jeremy near the end of the last development cycle and we agreed to
remove:
  Patch50: python-2.5-disable-egginfo.patch

early in Fedora-9 development and see if there were any problems with turning
egg-info back on.

Version-Release number of selected component (if applicable):
python-2.5.1-17
Comment 1 Zhan, Yi 2007-12-20 22:23:47 EST
Seems a direct impact of this change is that many packages failed to build by
below error:

RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib/python2.5/site-packages/*-py2.5.egg-info

BZ #426188 and #426188 has been filed for this. So far there are about 20+
packages failed with this issue. If the patch do need to be removed, all the
related packages would need to do a little change to handle the egg file. 
Comment 2 Zhan, Yi 2007-12-20 22:31:02 EST
Fix a typo about "#426188 and #426188"...

The two BZs are:
#426183: python-sqlite2 has unpackaged files
#426188: dogtail fails to build due to installed unpackaged files
Comment 3 Jeremy Katz 2007-12-20 22:35:54 EST
Yes, some packages will need changes to include the egginfo files.  

Also, closing this as we are building eggs again

Note You need to log in before you can comment on or make changes to this bug.