Bug 414761 - drupal can't write to /var/lib/drupal
drupal can't write to /var/lib/drupal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: drupal (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 15:10 EST by Doncho N. Gunchev
Modified: 2007-12-10 10:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 21:26:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-12-06 15:10:40 EST
Description of problem:
The directory /var/lib/drupal is owned by root:apache, which is ok, but it's 
permissions are rwxr-xr-x. This makes uploading new files impossible.

Version-Release number of selected component (if applicable):
drupal-5.4-1.fc8

How reproducible:
every time

Steps to Reproduce:
1. install drupal
2. configure it
  
Actual results:
Drupal error message: "The directory files is not writable"

Expected results:
Writable by apache files directory.

Additional info:
I did chmod g+w to my /var/lib/drupal (it got rwxrwxr-x), but the update 
revived the original permissions (rwxr-xr-x).
Comment 1 Gwyn Ciesla 2007-12-06 15:18:21 EST
It's set not writable by default for security, but setting it %noconfig would
solve this.  Seems like a good idea to me.  Any objections, Mr. Kundrak?
Comment 2 Lubomir Kundrak 2007-12-06 15:29:42 EST
I wouldn't even mind having it writable by apache group by default. If I
understand correctly it is needed for proper function of certain drupal features
anyways, and doesn't seem like a security hazard to me.
Comment 3 Gwyn Ciesla 2007-12-06 15:36:14 EST
Then I'll just change the perms and be done with it.  You're right, it shouldn't
be, because there's no remote access at the default install anyway.  

Thanks!
Comment 4 Gwyn Ciesla 2007-12-07 07:48:17 EST
Fixed in rawhide.  Since everyone for whom this has broken will have corrected
it manually, and this is the only change, is it worth building for F-8 et. al.,
or should I wait for the next version?
Comment 5 Doncho N. Gunchev 2007-12-10 09:39:41 EST
There's drupal-5.5 now, no need to wait any longer :-) Drupal 5.5 fixes what 
5.4 broke and some more small things.
Comment 6 Gwyn Ciesla 2007-12-10 10:37:08 EST
Thanks, building in devel now, will push through the pipes AQAP.

Note You need to log in before you can comment on or make changes to this bug.