This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 41477 - Installation hangs (2attempts) and crashes (1attempt) & dumps anacdump.txt
Installation hangs (2attempts) and crashes (1attempt) & dumps anacdump.txt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 00:19 EDT by Ian Bytheway
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-25 06:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Bytheway 2001-05-21 00:19:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
Attempting to install a redhat7.1 on a new machine, cannot complete 
the installation process

How reproducible:
Always

Steps to Reproduce:
1.Install from cd
2.
3.
	

Actual Results:  Installation from cd is slow, eventually hangs (2
attempts)
In 1 case loading of packages from cd completed, and the system crashed
producing the anacdump.txt file included

Expected Results:  Installation completed quickly since this is a new
machine 

Additional info:

Local variables in innermost frame:
which: 4
dir: /mnt/sysimage/mnt/floppy
elements: ['', 'mnt', 'sysimage', 'mnt', 'floppy']
path: /mnt/sysimage/mnt
 
ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I455
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10
 
<failed>
Comment 1 Brent Fox 2001-05-21 09:14:28 EDT
Was there more to the bug report?  It doesn't look like the whole thing.
Comment 2 Ian Bytheway 2001-05-21 21:51:06 EDT
Apologies for my cut/paste error. The following appears in the anacdump.txt file
before the first line of what was given above:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, in
run    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1964, in
doInstall
    self.fstab.write (self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 885, in write
    iutil.mkdirChain(prefix + mntpoint)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 237, in
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage/mnt'

Local variables in innermost frame:
<etc as reported initially>
Comment 3 Brent Fox 2001-05-22 15:58:31 EDT
Can you explain exactly what you did to make the occur?  We've seen a few of
these in the past, and the bug reporters never supplied enough information for
us to duplicate the behavior.
Comment 4 Ian Bytheway 2001-05-23 01:18:37 EDT
The anacdump.txt file resulted after our 2nd attempt to instal RH7.1 The steps
we took were as follows:

Installation attempt 1.  
Boot from rh7.1 cd 1; As this is a brand new machine we partitioned the disk
with druid, making a swap partition of 512Mb, as well as / and /boot partitions.
The latter /boot partition was asked for by the installation software (and was
needed before being allowed to move on with the installation), although I wasn't
expecting the need to make such a partition. After about  90minutes of
slow-loading the contents of cd1 and many mini-hangs, I restarted the computer &
tried again.

Installation attempt 2.
Boot from rh7.1 cd 1; Partition info remembered, and progression through the
installation of cd 1 ok -- slower than expected but not hanging as much as
attempt 1. Loading from cd 2 also progressed ok, until the crash at what seemed
to be the final stage of the installation, and the dumping of anacdump.txt

Installation attempt 3.
Boot from rh7.1 cd 1;  Installation hangs during the installation of cd 1 --
didn't finish even though left overnight.

This is probably not all that helpful, sorry. I should add that the machine is
an ASUS A7V133 motherboard, an AMD Athlon-tbird 1.3G C Sock A cpu, 256Mb SDRAM
and an 18GB Seagate Cheeter diskdrive. We have successfully loaded rh7.1beta
onto a similarly configured machine, however.
Comment 5 Andrew Smith 2001-05-24 00:19:07 EDT
I have been trying to do a text install of a local magazine copy of RedHat 
Linux 7.1 (Australian Personal Computer June 2001) that I got yesterday and have
had 3 failures trying to get it to install also. The third failure also gave an 
anaconda error. 1st & 3rd times it has failed right near the end (well I'm not 
sure how close but less than 5 minutes before the end of a FULL install of 
RedHat 7.1 and possibly right at the end??)
I booted from boot.img floppy I created from RedHat 7.0 (using: dd if=boot.img 
of=/dev/fd0) then I installed over RedHat 7.0 - install ran OK until near/at end
2nd failure appears to be a media error - got a file missing error during 
install (pity you HAVE to reboot when that window comes up!) - I bought two 
copies of the magazine and switched to the second copy for the 3rd install - 
the Linux Install CD 2 in the first copy didn't look right - but in the 2nd 
copy it looks OK.

Config is:
6G hda:  dha1=1G dos6.22
         dha2=5G ext2 for full install
300M hdb (all swap)
Pentium 166 MMX with 64Mb RAM
1 CD Drive used for install: hdc: LG 52x CD-ROM CRD-8521B1.02
1 DVD Drive (not used during install): hdd: Creative MATSHITADVD-ROM SR-8581 
179B

Install options:
----------------
text install
disk druid used to configure drives as listed above
install EVERYTHING
no firewall
serial mouse selected (but no mouse plugged in) - Microsoft Serial Compat - 
emulate 3 buttons
static IP
Default language: Australian English (US English installed - since can't remove)
TZ: Australia Sydney
one user account defined (no name provided)


anacdump.txt is as follows:
===========================
Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1964, in 
doInstall
    self.fstab.write (self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 901, in write
    for (partition, relative, size) in self.swapList(devices = 1, files = 1):
SystemError: unknown opcode

Local variables in innermost frame:
size: 0
dev: fd0
devName: /dev/fd0
mntpoint: /mnt/floppy
reformat: 0
self: <fstab.NewtFstab instance at 824ce10>
format: %-23s %-23s %-7s %-15s %d %d

f: <open file '/mnt/sysimage/etc/fstab', mode 'w' at 9c4efa8>
fs: auto
prefix: /mnt/sysimage
labels: {'hda2': '/'}

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I25
sS'width'
p11
I80
sS'helpCb'
p12

<failed>
Comment 6 Andrew Smith 2001-05-24 00:23:50 EDT
Sorry - confusing comment in there ... I used RedHat 7.0 machine to create the 
boot floppy using dd, but I used the RedHat 7.1 CD boot.img to write on the 
floppy
Comment 7 Andrew Smith 2001-05-24 05:50:34 EDT
OK - looks like I got in too soon!
I reinstalled 7.0 - no problems
I then reinstalled 7.1 - no problems!
I guess that it was one of two things:
1) The boot floppy? (I recreated it using rawrite in DOS for this install)
2) I have a active KVM switch that I switched over during the install
   and I noticed the keyboard light on the switch flashing during the
   successful install after "Post Install" I may not have had the keyboard
   switched over during what would appear to be a hardware check during/after
   "Post Install" when it failed, but I did have it switched over during the
   successful install.
Comment 8 Brent Fox 2001-05-24 13:15:32 EDT
ianb, can you look on VC3 and VC4 during the install and see if you see any
error messages?  Specifically, look for cdrom related messages.
Comment 9 Ian Bytheway 2001-05-25 06:02:35 EDT
Looking at VC4 during another installation attempt we saw many scsi errors of
the type
scsi: aborting comand due to timeout
scsi disk error ... return code= 25050000

We decided (after much playing around) to force the scsi to be single-ended,
after which the installation was *successful*. We plan to get a faster scsi
cable (ie the one that was actually ordered).

The advice to look at VC3 and VC4 was worthwhile thanks.

Note You need to log in before you can comment on or make changes to this bug.