Bug 414811 - gtkterm hangs when virtual serial device is disconnected
gtkterm hangs when virtual serial device is disconnected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtkterm (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 15:33 EST by Olof Tångrot
Modified: 2007-12-26 20:03 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.99.5-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-26 20:02:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olof Tångrot 2007-12-06 15:33:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc8 Firefox/2.0.0.10

Description of problem:
gtkterm floods console with "Control signals read: Input/output error" when virtual serial USB device is disconnected. Also gtkterm menus are locked and connection can not be terminated without less than killing gtktem.

Problem also existing on Fedora 7 and Fedora Core 6 (IA32 arch.)

SiLabs CP2102 USB to UART bridge is used as USB driver.

Don't think it's a device driver problem.
cat /dev/ttyUSB0 will simply return to the console if the USB device is disconnected.



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Connect USB device to the mainframe.
2. Start a xterm session to get a command promt.
3. Start gtkterm and select port /dev/ttyUSB0 (or whatever) and correct serial speed
4. Wait for some communication from the virtual terminal
5. Disconect USB device

Actual Results:
The xterm (stdout or stderr) is flooded with "Control signals read: Input/output error
"

gtkterm menus are locked.

Expected Results:
A graceful handling of the exception. Typically terminal program indicates disconnected and allows the user to make a new connection.

No flooding of stderr or stdout should occur.

Additional info:
Comment 1 Dan Horák 2007-12-09 04:19:58 EST
Can you try a new rpm from
http://koji.fedoraproject.org/koji/taskinfo?taskID=284092 ?
Comment 2 Hans de Goede 2007-12-09 04:54:24 EST
Thanks for picking this up Dan, I've been really busy working on something else
(keep an eye on planet.fedoraproject.org for an announcement tomorrow), so I
appreciate you picking up this (and other gtkterm bugs).
Comment 3 Dan Horák 2007-12-09 05:16:04 EST
(In reply to comment #2)
> Thanks for picking this up Dan, I've been really busy working on something else
> (keep an eye on planet.fedoraproject.org for an announcement tomorrow), so I
> appreciate you picking up this (and other gtkterm bugs).
> 

No problem, Hans. As I and my colleagues are using gtkterm in work, I am fixing
the bugs for myself too :-) Now I only hope that the one-liner will fix this
issue as I have no serial device at home. But at least I see no problems when
pluging and unpluging just the USB<->serial converter cable.
Comment 4 Olof Tångrot 2007-12-10 03:09:18 EST
The new package works on my x86_64 Fedora 8 machine as I originally (get ready 
for a small scope creep) intended. Though there are a small spot in the user 
interface relvealed now.

The MMI still indicates that /dev/ttsUSB0 is connected. Now, if I reconnect the 
USB-device the connection is not resumed. I have to enter the menu and reselect 
the same port before it does. This is confusing to the user. 

I belive it would be more user friendly if the disconnected state of the 
selected prot is indicated someway in the MMI. Also if the USB-device is 
reconnected it's a very nice feature to get the port automatically reconnected.

Olof
Comment 5 Dan Horák 2007-12-10 04:03:59 EST
(In reply to comment #4)
> The new package works on my x86_64 Fedora 8 machine as I originally (get ready 
> for a small scope creep) intended. Though there are a small spot in the user 
> interface relvealed now.
> 

OK, I will officially build the package and then close this bug.


> The MMI still indicates that /dev/ttsUSB0 is connected. Now, if I reconnect the 
> USB-device the connection is not resumed. I have to enter the menu and reselect 
> the same port before it does. This is confusing to the user. 
> 
> I belive it would be more user friendly if the disconnected state of the 
> selected prot is indicated someway in the MMI. Also if the USB-device is 
> reconnected it's a very nice feature to get the port automatically reconnected.

This is more an upstream issue. Because upstream is not very responsive, I will
place this into my to-do list but without any fixed deadline.
Comment 6 Fedora Update System 2007-12-15 12:46:04 EST
gtkterm-0.99.5-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkterm'
Comment 7 Fedora Update System 2007-12-15 12:46:59 EST
gtkterm-0.99.5-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkterm'
Comment 8 Olof Tångrot 2007-12-20 16:15:34 EST
Tested on Fedora 8 x86_64. It works, gtkterm MMI does not hang and the terminal
is not flooded.
Comment 9 Fedora Update System 2007-12-23 17:49:49 EST
gtkterm-0.99.5-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkterm'
Comment 10 Fedora Update System 2007-12-23 17:50:22 EST
gtkterm-0.99.5-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkterm'
Comment 11 Fedora Update System 2007-12-26 18:51:35 EST
gtkterm-0.99.5-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkterm'
Comment 12 Fedora Update System 2007-12-26 18:52:29 EST
gtkterm-0.99.5-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkterm'
Comment 13 Fedora Update System 2007-12-26 20:02:34 EST
gtkterm-0.99.5-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2007-12-26 20:03:03 EST
gtkterm-0.99.5-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.