Bug 41490 - builtin ripper blocks on device open after first mp3 encode completes
builtin ripper blocks on device open after first mp3 encode completes
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: grip (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 02:11 EDT by j. alan eldridge
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 02:16:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to close fds before exec (453 bytes, patch)
2001-05-21 02:13 EDT, j. alan eldridge
no flags Details | Diff
write debug out to stderr, unbuffer stdout so debugging is useful (955 bytes, patch)
2001-05-21 02:13 EDT, j. alan eldridge
no flags Details | Diff
updated spec file including my patches (2.93 KB, text/plain)
2001-05-21 02:14 EDT, j. alan eldridge
no flags Details
a source RPM for 2.95 with my patches + the makefile patch (233.78 KB, application/octet-stream)
2001-05-21 02:15 EDT, j. alan eldridge
no flags Details

  None (edit)
Description j. alan eldridge 2001-05-21 02:11:56 EDT
Description of Problem:

The built-in ripper (cdparanoia library) blocks on device open after the 
first mp3 encode completes. This is because the file descriptor for the 
device is being inherited by the (2nd and later) child (encoder) process 
which is forked off while a rip is going on. Patch is to close all fds > 
2 (stderr) after fork but before exec (in my patch, this is done in 
RedirectIO() in grip.c).

Additional information:

This problem persists into version 2.95. My original patches were created 
for this version. Program author has been informed of bug and of patches.
Comment 1 j. alan eldridge 2001-05-21 02:13:01 EDT
Created attachment 19110 [details]
patch to close fds before exec
Comment 2 j. alan eldridge 2001-05-21 02:13:48 EDT
Created attachment 19111 [details]
write debug out to stderr, unbuffer stdout so debugging is useful
Comment 3 j. alan eldridge 2001-05-21 02:14:39 EDT
Created attachment 19112 [details]
updated spec file including my patches
Comment 4 j. alan eldridge 2001-05-21 02:15:58 EDT
Created attachment 19113 [details]
a source RPM for 2.95 with my patches + the makefile patch
Comment 5 Tim Powers 2001-05-21 10:13:30 EDT
I applied your patches for closing the fd, and for debugging. The new package
(with credit towards you) should show up in rawhide shortly.

Tim

Note You need to log in before you can comment on or make changes to this bug.