Bug 41510 - cannaserver cannot start up for getting SIGSEGV
cannaserver cannot start up for getting SIGSEGV
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Canna (Show other bugs)
7.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nakai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 03:57 EDT by Takanori Kawano
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 18:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the result of 'strace cannaserver' (Canna-3.5b2-41) (3.00 KB, text/plain)
2001-05-21 04:03 EDT, Takanori Kawano
no flags Details
This is of Canna-3.5b2-42 (9.14 KB, text/plain)
2001-05-21 04:11 EDT, Takanori Kawano
no flags Details
Results of 'strace cannaserver -d > cannaserver_d.out 2> cannaserver_d.err' (10.73 KB, text/plain)
2001-05-22 04:28 EDT, Takanori Kawano
no flags Details

  None (edit)
Description Takanori Kawano 2001-05-21 03:57:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
Cannaserver did not start up at boot, and when I enter the 
command 'cannaserver', It also did not start up and 
displayed 'Segmentation fault'.
The segmentation fault disappered after upgrading cannaserver to Canna-
3.5b2-42.ia64.rpm, but this also did not start up for getting SIGTERM.

I got these results on Bigsur(1CPU, B3 stepping, FW build 99).

Output of 'strace cannaserver' is attached.


How reproducible:
Always

Steps to Reproduce:
1. Type 'cannaserver'
2.
3.
	

Additional info:
Comment 1 Takanori Kawano 2001-05-21 04:03:12 EDT
Created attachment 19130 [details]
This is the result of 'strace cannaserver' (Canna-3.5b2-41)
Comment 2 Takanori Kawano 2001-05-21 04:11:13 EDT
Created attachment 19131 [details]
This is of Canna-3.5b2-42
Comment 3 Nakai 2001-05-21 07:44:40 EDT
Canna-3.5b2-42 really works here on Hitachi ia64, so we need
more info.

cannaserver.42.log says that its child process is dead.

Could you show us an strace log of 'cannaserver -d' and
both stdout and stderr messages.
(RHL7.1 IA64 will be shipped in this few days.)
Comment 4 Takanori Kawano 2001-05-22 04:28:42 EDT
Created attachment 19270 [details]
Results of 'strace cannaserver -d > cannaserver_d.out 2> cannaserver_d.err'
Comment 5 Takanori Kawano 2001-05-22 04:29:02 EDT
Results of 'strace cannaserver -d > cannaserver_d.out 2> cannaserver_d.err'
 is attached.
(cannaserver_d.out is empty and not attached)

I think the log of cannaserver.42.log may show the ordinary behavior of 
cannaserver
(The child process to be running as daemon sent SIGTERM to its parent process
to clean up.) 
and this is not a problem, but I cannot be convinced this completely because I 
observed that
/etc/init.d/canna restart 
still fails after upgrading to Canna-3.5b2-42.
(while starting cannaserver at boot succeed and displayed [OK].)

[root@localhost /root]# /etc/init.d/canna restart
Stopping cannaserver: [  OK  ]
Starting cannaserver: [FAILED]
Comment 6 Ben Levenson 2001-06-01 17:04:45 EDT
FWIW, I'm seeing similar behavior on the Big Sur I've been testing with.
build qa0530.0
Canna-3.5b2-42.ia64.rpm

canna service displays [FAILED] message during system boot,
but after the system finishes booting:
# service canna status
cannaserver (pid 903) is running...
I also verified that cannaserver was running w/ ps.
Comment 7 Glen Foster 2001-07-13 18:11:48 EDT
We (Red Hat) really need to fix this before next release.
Comment 8 Bill Nottingham 2001-08-14 01:32:46 EDT
This appears to work for me with a relatively recent build. (3.5b2-43.)

Note You need to log in before you can comment on or make changes to this bug.