Bug 41554 - gcc Internal compiler error: Error reporting routines re-entered
gcc Internal compiler error: Error reporting routines re-entered
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 52614 60491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 06:46 EDT by Fredrik Sandstrvm
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 08:01:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fredrik Sandstrvm 2001-05-21 06:46:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
gcc crashes after a syntax error is reported. Seems like the gcc error
report routine can't print the error line without crashing.


How reproducible:
Always

Steps to Reproduce:
1. The program needs only to contain the following two bytes to cause the
crash.
[fredde@itchy src]$ hexdump bug.cpp 
0000000 0aa0                                   
0000002

2. [fredde@itchy src]$ gcc -c bug.cpp 
bug.cpp:1: universal-character-name `\u
Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report.

3. Write bug report
	

Actual Results:  bug.cpp:1: universal-character-name `\u
Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report.

Expected Results:  bug.cpp:1: universal-character-name `\u'
syntax error

Additional info:
Comment 1 Jakub Jelinek 2001-06-01 08:01:03 EDT
The diagnostic routines did not cope with %08x format. Will be fixed
in gcc-2.96-86.
Comment 2 Jakub Jelinek 2001-08-27 07:07:11 EDT
*** Bug 52614 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Jelinek 2002-03-04 09:19:30 EST
*** Bug 60491 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.