Bug 415561 - add serial console capability to qemu and qemu-kvm guests
add serial console capability to qemu and qemu-kvm guests
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 07:43 EST by Jeff Layton
Modified: 2014-06-18 03:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.4.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 06:05:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2007-12-07 07:43:30 EST
With xen, I can use the serial port that shows up in the VM and use "virsh
console guest" to attach to its pty. With qemu and qemu-kvm, the kernel seems to
recognize an emulated serial port, but I don't seem to be able to attach to it
with "virsh console".

Would it be possible to add the same serial console capability to kvm and qemu
guests?
Comment 1 Jeff Layton 2007-12-07 07:50:37 EST
It looks like this would be a matter of adding a new command line parameter to
the qemu command "-serial pty", keeping track of the pty device that it outputs
to stdout, and then attaching to that pty in the same way that xen consoles do...
Comment 2 Bug Zapper 2008-05-14 00:07:07 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Daniel Berrange 2008-07-09 06:05:45 EDT
Serial console support was added in libvirt 0.4.4

Note You need to log in before you can comment on or make changes to this bug.