Bug 41593 - Very Tiny Fonts in the DeskTop running instalation in Spanish
Very Tiny Fonts in the DeskTop running instalation in Spanish
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gmc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Mason
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-21 11:01 EDT by Pablo Gonzalo del Campo
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 15:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ultra-small fonts in icons text (3.13 KB, image/jpeg)
2001-05-21 12:12 EDT, Pablo Gonzalo del Campo
no flags Details

  None (edit)
Description Pablo Gonzalo del Campo 2001-05-21 11:01:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95; NetCaptor 
6.2.1A)

Description of problem:
After the instalation has finished and restart the PC in the Gnome Desktop 
i get very tiny fonts at 1024x768. I check that the 100 dpi fonts has been 
installed and this is OK.
The occurs in a "clean" instalation using the Spanish Language.

How reproducible:
Always

Steps to Reproduce:
1. Install Usign Spanish Language and choosing a resolution of 1024x768, 
doing a WorkStation or a Custom instalation
2. Finish the Instalation.
3. Start the Gnome DeskTop.
	

Actual Results:  I Get Very Small and unreadable fonts in the Desktop

Expected Results:  A font "normal"

Additional info:

My Graphic Card is a 3dfx 3000 - 16 Mb RAM
Pentium II 300 MB - 256 Mb RAM
Comment 1 David Mason 2001-05-21 11:06:41 EDT
Just installing the 100dpi fonts doesnt mean you are using them: You must make
sure that your X configuration uses these fonts *first* - to do so you should
move all *100dpi* fonts above *75dpi* fonts in your /etc/X11/fs/config file -
like this example:

 catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
	/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/X11R6/lib/X11/fonts/Type1,
	/usr/X11R6/lib/X11/fonts/Speedo,
	/usr/X11R6/lib/X11/fonts/cyrillic,
	/usr/X11R6/lib/X11/fonts/100dpi,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/usr/share/fonts/default/Type1,
	/usr/share/fonts/default/TrueType,
	/usr/share/fonts/pango-fonts,
	/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/latin2/100dpi,
	/usr/share/fonts/ja/TrueType

Please use what is in there and move them around - do not add the lines above
from my file!

Also, in the same file you need to make sure that the 'default-resolutions' are
calling 100 dpi first as well - like so:

# 100 x 100 and 75 x 75
default-resolutions = 100,100,75,75

Give that a shot - any better?
Comment 2 Pablo Gonzalo del Campo 2001-05-21 11:34:10 EDT
Thanks by the trick, but the instalation leave me a config for the fs like this:

catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/X11R6/lib/X11/fonts/Type1,
	/usr/X11R6/lib/X11/fonts/Speedo,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/usr/X11R6/lib/X11/fonts/100dpi,
	/usr/share/fonts/default/Type1,
	/usr/share/fonts/ja/TrueType

# in 12 points, decipoints
default-point-size = 120

# 100 x 100 and 75 x 75
default-resolutions = 75,75,100,100

?Is "The Bug" in the default-resolutions setting? 

Grettings.
Comment 3 David Mason 2001-05-21 11:40:35 EDT
well it is both from having the default resolution call 75 first, and from
having the 75 dpi fonts listed first in the font catalogue. In your case you
would change it to this:

catalogue = /usr/X11R6/lib/X11/fonts/100dpi:unscaled,
	 /usr/X11R6/lib/X11/fonts/misc:unscaled,
         /usr/X11R6/lib/X11/fonts/75dpi:unscaled,
         /usr/X11R6/lib/X11/fonts/misc,
         /usr/X11R6/lib/X11/fonts/Type1,
         /usr/X11R6/lib/X11/fonts/Speedo,
	 /usr/X11R6/lib/X11/fonts/100dpi,
         /usr/X11R6/lib/X11/fonts/75dpi,
         /usr/share/fonts/default/Type1,
         /usr/share/fonts/ja/TrueType

 # in 12 points, decipoints
 default-point-size = 120

 # 100 x 100 and 75 x 75
 default-resolutions = 100,100,75,75


Then restart X
Comment 4 Pablo Gonzalo del Campo 2001-05-21 12:12:46 EDT
Created attachment 19170 [details]
ultra-small fonts in icons text
Comment 5 Pablo Gonzalo del Campo 2001-05-21 12:14:03 EDT
:-(((,

The modification to the config file does not work, after modify the file and 
restart the xfs and X I get the same results ...

Any other idea?

Please take a look to the attach to see how look my icon4s desktop ...
Comment 6 David Mason 2001-05-21 12:15:14 EDT
this does not look like a problem with X using or not using 100 dpi fonts.... is
this just on your desktop icons?
Comment 7 Pablo Gonzalo del Campo 2001-05-21 12:21:48 EDT
Yes, this happen just with the icon4s text, the rest of Gnome works great ...

Comment 8 David Mason 2001-05-21 12:28:26 EDT
ok thanks - probably a gmc issue: assigning
Comment 9 Pablo Gonzalo del Campo 2001-05-30 10:27:29 EDT
I Have a solution for the "Bug" ...

The problem is in my /etc/i18n file, I have the following:

LANG="es_ES@euro"
SUPPORTED="es_AR:es:es_ES@euro:es_ES:es"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

I Replace with (come from another instalation):

LANG="es_AR"
SUPPORTED="es_AR:es:es_ES@euro:es_ES:es"
SYSFONT="lat0-sun16"
SYSFONTACM="iso01"

Try It, don4t fail ...

Grettings.


Comment 10 LENHOF 2001-07-01 16:41:38 EDT
Hi boys,

I've exactly the same problem.
The only workaround is to remove the text euro in the LANG of /etc/sysconfig/i18n

For me replacing this

[root@localhost /root]# more /etc/sysconfig/i18n 
LANG=fr_FR@euro
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"
[root@localhost /root]# 

with

[root@localhost /root]# more /etc/sysconfig/i18n 
LANG=fr_FR
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"
[root@localhost /root]# 

works....

(And I upgraded GDM to 2.2.1 and with this change the font is not the same)

Though
I tried a new version of gettext...but it doesn't seem to help also...
I don't know where's the problem with localisation...
Comment 11 Jonathan Blandford 2001-07-24 16:03:25 EDT
I don't think this is a gmc issue.  Additionally, gmc is no longer supported in
favor of Nautilus.  dcm, can we close this or should we move it elsewhere?

Note You need to log in before you can comment on or make changes to this bug.