Bug 416011 - hts DVD-RW test failed
hts DVD-RW test failed
Status: CLOSED DUPLICATE of bug 432025
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
low Severity high
: ---
: ---
Assigned To: YangKun
Red Hat Hardware Certification
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 15:12 EST by Shengliang Lv
Modified: 2008-07-16 17:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 01:57:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The results file of the test. (308.26 KB, text/xml)
2007-12-07 15:12 EST, Shengliang Lv
no flags Details

  None (edit)
Description Shengliang Lv 2007-12-07 15:12:56 EST
Description of problem:
When I did CDROM certification on HP integrity Superdome, when it test DVD-FW, 
I got the following errors:

  +++ Blank disk done !


  +++ Start writing ...

Driver flags   : SWABAUDIO BURNFREE
sh: -c: line 0: syntax error near unexpected token `('
sh: -c: line 0: `{ mkisofs -quiet -R /usr/share | cdrecord -v -sao 
driveropts=burnfree dev=/dev/scd0 fs=32M tsize=Unknown file type 
(unallocated) /usr/share/.. - ignoring and continuing.'

  +++ Write options : -sao driveropts=burnfree



  +++ Error: Write disk failed !


 CDROM test on device scd0 failed
...finished running ./cdrom.py, exit code=1
recovered exit code=1
hts-report-result /HTS/hts/cdrom FAIL /var/log/hts/runs/1/cdrom/output.log
saveOutput: /var/log/hts/runs/1/cdrom/output.log
Return value was 0

Version-Release number of selected component (if applicable):
Kernel: 2.6.18-53.el5xen
HTS: hts-5.1-13

How reproducible:


Steps to Reproduce:
1.hts certify --test cdrom
2.put a CD-RW and then a DVD-RW disk in DVDRW drive.
3.
  
Actual results:
DVD-FW test failed.

Expected results:
DVD-FW test pass.

Additional info:
Comment 1 Shengliang Lv 2007-12-07 15:12:56 EST
Created attachment 281541 [details]
The results file of the test.
Comment 2 Shengliang Lv 2007-12-12 13:34:39 EST
This issue isn't fixed in hts-5.1-16.
Comment 3 YangKun 2007-12-12 21:31:07 EST
I can not re-produce your error on my "Philips DVD+/-RW DVD8801" writer. Seems
you're using a "NEC DVD_RW ND-3540A" DVD writer, could this be a device related
issue instead of an OS/HTS issue ? Could you please ship one of your DVD writers
to me for investigation ?

Thanks
-YK
Comment 4 Shengliang Lv 2007-12-13 14:34:03 EST
YangKun,
  I use command "growisofs -Z /dev/scd0=file.iso" to write this DVD, it works 
find, so I don't think it's a hardware issue.
Comment 5 Shengliang Lv 2007-12-14 19:47:31 EST
Yangkun,
  Our DVD writer on this machine(NEC DVD_RW ND-3540A) is a DVD+RW writer, today 
I selected DVD+RW test and use a DVD+RW disk to do the test, it passed.

  HTS report the DVD writer can support DVD-RW disk, maybe it's a problem.
Comment 6 YangKun 2007-12-16 21:25:14 EST
Shengliang,

HTS relies on HAL to discover optical drive features, and it shows this drive
does support both DVD-RW and DVD+RW:
--------------------------------------------------
  info.product = DVD_RW ND-3540A
  info.udi = /org/freedesktop/Hal/devices/storage_model_DVD_RW_ND_3540A
  info.vendor = _NEC 
  linux.hotplug_type = 3
  linux.sysfs_path = /sys/block/sr0
  linux.sysfs_path_device = /sys/block/sr0
  org.freedesktop.Hal.Device.Storage.method_argnames = ['extra_options',
'extra_options']
  org.freedesktop.Hal.Device.Storage.method_execpaths = ['hal-storage-eject',
'hal-storage-closetray']
  org.freedesktop.Hal.Device.Storage.method_names = ['Eject', 'CloseTray']
  org.freedesktop.Hal.Device.Storage.method_signatures = ['as', 'as']
  storage.automount_enabled_hint = True 
  storage.bus = scsi 
  storage.cdrom.bd = False
  storage.cdrom.bdr = False
  storage.cdrom.bdre = False
  storage.cdrom.cdr = True 
  storage.cdrom.cdrw = True 
  storage.cdrom.dvd = True 
  storage.cdrom.dvdplusr = True 
  storage.cdrom.dvdplusrdl = True 
  storage.cdrom.dvdplusrw = True 
  storage.cdrom.dvdplusrwdl = False
  storage.cdrom.dvdr = True 
  storage.cdrom.dvdram = False
  storage.cdrom.dvdrw = True 
  storage.cdrom.hddvd = False
  storage.cdrom.hddvdr = False
  storage.cdrom.hddvdrw = False
  storage.cdrom.read_speed = 7056 
  storage.cdrom.support_media_changed = True 
  storage.cdrom.write_speed = 706
  storage.cdrom.write_speeds = ['706']
  storage.drive_type = cdrom
  storage.firmware_version = 1.30 
  storage.hotpluggable = False
  storage.lun = 0
  storage.media_check_enabled = True 
  storage.model = DVD_RW ND-3540A
  storage.no_partitions_hint = True 
  storage.partitioning_scheme = 
  storage.physical_device =
/org/freedesktop/Hal/devices/pci_1000_30_0_scsi_host_scsi_device_lun0
  storage.removable = True 
  storage.removable.media_available = True 
  storage.removable.media_size = 3312996352
  storage.requires_eject = True 
  storage.size = 0
  storage.vendor = _NEC 
-------------------------------------------------- 

I think this can either be an HAL's bug or be an "optical drive's fireware not
consistent with it's capabilities" issue. 

Could you please provide the information shown in file "/proc/sys/dev/cdrom/info" ?

Thanks very much.
-YK
Comment 7 Shengliang Lv 2007-12-17 00:31:05 EST
# cat info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             sr0
drive speed:            40
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           1
Can write DVD-R:        1
Can write DVD-RAM:      0
Can read MRW:           0
Can write MRW:          0
Can write RAM:          1
Comment 8 YangKun 2007-12-17 03:19:20 EST
Shengliang,

Thanks for this info:) seems kernel also "sees" this drive supports DVD-R/RW. Do
you have the detailed specification for this optical drive ? Does the spec say
this drive not supporting DVD-R/RW ?

Could you please help me to do one more test: please use "mkisofs" or k3b or any
other recording software to "write" a DVD-R(or DVD-RW) disk, see if it works.

Thank you very much :)
-YK
Comment 9 Shengliang Lv 2007-12-17 18:48:01 EST
Yangkun,
  I don't have the detail spec for this optical drive.

  I ever used "growisofs -Z /dev/scd0=file.iso" to write DVD-RW and DVD+RW 
disks, it worked fine.

Comment 10 YangKun 2007-12-19 02:24:47 EST
Shengliang,

Could you please use "mkisofs" instead of "growisofs" to check again ?

Thank you very much.
-YK
Comment 11 YangKun 2008-03-05 01:57:04 EST

*** This bug has been marked as a duplicate of 432025 ***

Note You need to log in before you can comment on or make changes to this bug.