Bug 416061 - /etc/dhclient-wlan0.conf not working
/etc/dhclient-wlan0.conf not working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 15:49 EST by Levente Farkas
Modified: 2008-06-23 10:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: F-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 10:59:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2007-12-07 15:49:27 EST
Description of problem:
while in fedora 7 it was working with fedora 8 and networkmanager
/etc/dhclient-wlan0.conf:
supersede domain-name "example.com";
supersede domain-name-servers 192.168.0.2, 192.168.0.1;
no longer works.

Version-Release number of selected component (if applicable):


How reproducible:
just connect to a wireless ap.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
just the dhcp server provided parameters are set.

Expected results:
modify the dhcp server provided data with the according to /etc/dhclient-wlan0.conf

Additional info:
Comment 1 David Cantrell 2008-01-10 21:13:26 EST
(Changed component...dhcdbd is not part of F-8.)
Comment 2 David Cantrell 2008-01-10 21:14:00 EST
Are you sure your wireless interface is called wlan0 in Fedora 8?
Comment 3 matt rice 2008-01-20 09:40:27 EST
I'm seeing something similar here, seems to be a network manager bug,
dhclient-iface.conf is used for non-network manager enabled interfaces and
ignored for network-manager enabled ones.

below is the arguments used to start dhclient from network manager,

/sbin/dhclient -d -sf /usr/libexec/nm-dhcp-client.action -pf
/var/run/dhclient-wlan0.pid -lf /var/run/dhclient-wlan0.lease wlan0

so it seems network manager needs to be taught about the -cf flags

Comment 4 Levente Farkas 2008-02-15 16:17:25 EST
yes i'm sure i've wlan0 and it works as i do manual ifup wlan0 and it use
/etc/dhclient-wlan0.conf in that case, but if i start networkmanager than it no
longer use /etc/dhclient-wlan0.conf which is imho a bug! since currently there
is no any other way (or at least i don't know) how to force some kind of options
like:
supersede domain-name "example.com";
supersede domain-name-servers 192.168.0.2, 192.168.0.1;
Comment 5 Callum Macdonald 2008-04-19 03:47:55 EDT
I have found something similar in NetworkManager-0.7.0-0.9.1.svn3549.fc9

My /etc/dhclient.conf contains:
prepend domain-name-servers 127.0.0.1;

This was respected under the F8 version of NetworkManager, but is now ignored
since I upgraded. However, if I copy the same file as /etc/dhclient-wlan0.conf
then it *does* work. It correctly prepends the nameserver 127.0.0.1 to
/etc/resolv.conf on connection.
Comment 6 Levente Farkas 2008-06-18 14:21:04 EDT
please close this bug since it's been already solved
Comment 7 David Cantrell 2008-06-23 10:59:53 EDT
Closing per comment #6

Note You need to log in before you can comment on or make changes to this bug.