Bug 416111 - Yum module error
Yum module error
Status: CLOSED UPSTREAM
Product: Fedora EPEL
Classification: Fedora
Component: func (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 16:12 EST by Steve Milner
Modified: 2014-01-21 18:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 14:34:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Milner 2007-12-07 16:12:27 EST
Description of problem:
$ func scrubbed.host call yum update
func scrubbed.host call yum update on scrubbed.host:51234 running yum update ()
remote exception on scrubbed.host:51234: <Fault 1:
"exceptions.AttributeError:'module' object has no attribute 'YumBase'">


Version-Release number of selected component (if applicable):
$ rpm -qa | grep func
func-0.13-3.el5
$

How reproducible:
For me on RHEL5 everytime.

Steps to Reproduce:
1. Install func from EPEL
2. Set it up per
https://hosted.fedoraproject.org/projects/func/wiki/InstallAndSetupGuide
3. run func scrubbed.host call yum update
  
Actual results:
func scrubbed.host call yum update on scrubbed.host:51234 running yum update ()
remote exception on scrubbed.host:51234: <Fault 1:
"exceptions.AttributeError:'module' object has no attribute 'YumBase'">

Expected results:
That it attempts to update

Additional info:
$ uname -a
Linux scrubbed.host 2.6.18-8.1.15.el5 #1 SMP Thu Oct 4 04:06:15 EDT 2007 i686
i686 i386 GNU/Linux
$ python -V
Python 2.4.3
Comment 1 Steve Milner 2009-01-19 14:34:38 EST
Closing this since it's old and bugs don't go here any more.

Note You need to log in before you can comment on or make changes to this bug.